summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilip Sequeira2017-10-30 19:59:07 -0400
committerPhilip Sequeira2017-10-30 19:59:07 -0400
commitf9e2bdd2d3fa36272f9841975fa730d52affcd3e (patch)
tree9b2ee4ff340c65a91905d5e4ef28ad7640be2139 /PKGBUILD
parent26af1fc9fb7b1437049119b1019a1c9c45634df9 (diff)
downloadaur-f9e2bdd2d3fa36272f9841975fa730d52affcd3e.tar.gz
update ffmpeg workaround
Can't just revert the commit anymore, as the surrounding code has changed since. Add a patch with a simple workaround that will hopefully not break too often. PR #5033 has been merged(ish) upstream. Remove the patch. mpv now requires git master ffmpeg; the latest release is not new enough. This package probably should start depending on ffmpeg-git, but I'm not switching it yet because that isn't provided by the current ffmpeg-mpv-git package. We'll just live with the _dirty in the version for now. If this goes on, I'll strip it from the pkgver, but it will stay in the built binary as long as it's true, to respect those handling bug reports upstream. Some kind of option to avoid applying the patch when using ffmpeg-mpv should be doable, though, so those who are following upstream's recommendations can get a fully supported build without -dirty.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e30790bff638..a0baf9a252a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -48,7 +48,7 @@ _opt_features=(
pkgname=mpv-git
_gitname=mpv
-pkgver=0.27.0_310_ga00a2266a0
+pkgver=0.27.0_322_g0b8b64fba3_dirty
pkgrel=1
pkgdesc='Video player based on MPlayer/mplayer2 (git version)'
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
@@ -63,13 +63,13 @@ conflicts=('mpv')
options=('!emptydirs')
install=mpv.install
source=('git+https://github.com/mpv-player/mpv'
- '5033.patch'
+ 'allow-upstream-ffmpeg.patch'
'find-deps.py')
md5sums=('SKIP'
- '2292f053f7e2e5a32fcf778746c25265'
+ 'dcc4e3bd6722b120d13d0dc9b6e6a791'
'ffb774b13decbefc62908dda0332046b')
sha256sums=('SKIP'
- '8d46d9ba280a48248f28feeb3d2ff28a16dbd0a5eea8d9178756590de9e3e421'
+ '93f92ac06e815d2eaedacb161b57e2d68086566bf2c9942dd6fc0ad16dc71272'
'ce974e160347202e0dc63f6a7a5a89e52d2cc1db2d000c661fddb9dc1d007c02')
_opt_extra_flags=()
@@ -135,9 +135,7 @@ prepare() {
cd "$srcdir/$_gitname"
./bootstrap.py
- # Temporary workaround (see AUR comments)
- git revert --no-edit 83d44aca7dc7f46b8d3b64d441f5a8317a40e080
- git am "$srcdir/5033.patch"
+ git apply "$srcdir/allow-upstream-ffmpeg.patch"
}
build() {