summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortdy2017-02-06 06:52:53 -0600
committertdy2017-02-06 06:52:53 -0600
commit2fa7a769588810ef130ca33aff84487b4a094b8d (patch)
tree1aee0fc1db0adf5e91adb32214d81da6dfe11d23 /PKGBUILD
downloadaur-2fa7a769588810ef130ca33aff84487b4a094b8d.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eded18c22142
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: archlinux.info:tdy
+
+pkgname=mpv-notify-git
+pkgver=r19.019e278
+pkgrel=1
+pkgdesc="Desktop notifications for the mpv media player"
+arch=(any)
+url=https://github.com/rohieb/mpv-notify
+license=(MIT)
+depends=(lua52-socket lua52-posix libnotify imagemagick)
+source=($pkgname::git+https://github.com/rohieb/mpv-notify.git)
+sha256sums=(SKIP)
+
+pkgver() {
+ cd $pkgname
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+prepare() {
+ cd $pkgname
+ sed -n 4,22p notify.lua > COPYING
+}
+
+package() {
+ cd $pkgname
+ install notify.lua -m 644 -Dt "$pkgdir"/usr/share/${pkgname%-git}/
+ install COPYING -m 644 -Dt "$pkgdir"/usr/share/licenses/$pkgname/
+}