summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArctic Ice Studio2018-12-15 12:49:05 +0100
committerArctic Ice Studio2018-12-15 12:49:05 +0100
commit91d90f6d9cec169702cdf3fb28e91188700f8bfe (patch)
tree785c0558a79f4b07c265d079e67eee3629e4817b /PKGBUILD
parent31674dec1f64c04d6177605c3e39b9426c18c995 (diff)
downloadaur-91d90f6d9cec169702cdf3fb28e91188700f8bfe.tar.gz
Update to upstream version 1.7.1
The name of the directory and binary is now uppercase again.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f809070de019..a0e4f0d32045 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Arctic Ice Studio <development@arcticicestudio.com>
pkgname=mqttfx-bin
_pkgbasename=mqttfx
-pkgver=1.7.0
+pkgver=1.7.1
pkgrel=1
pkgdesc="A MQTT Client written in Java based on Eclipse Paho"
arch=("x86_64")
@@ -15,12 +15,13 @@ source=(
"${_pkgbasename}.png"
)
sha256sums=(
- "06153aa3176e74ee8e8d5995ff6f9b74bc57327987f934a7b1688a30fcdc5a3f"
+ "6fb14c739cbf8b54a373a0c5c173ef3657c01c675374ded8f0a292c610e549c2"
"741674f5b782aa4de0b071b7f49484b74ee2150e38b5d83eb4bd00b172978e2a"
"6c1b23755d3b1832ddb643b585d623128cde38e2ef42e7839141cf2106b0a59e"
)
package() {
+ local bin_name=MQTTfx
cd "${srcdir}"
# Extract the application data into the package directory root
@@ -28,7 +29,7 @@ package() {
# Install the binary directory and link into package
install -dm755 "${pkgdir}/usr/bin"
- ln -s "/opt/${_pkgbasename}/${_pkgbasename}" "${pkgdir}/usr/bin/${_pkgbasename}"
+ ln -s "/opt/${bin_name}/${bin_name}" "${pkgdir}/usr/bin/${_pkgbasename}"
# Install the application logo and desktop launcher
install -Dm644 "${_pkgbasename}.png" "${pkgdir}/usr/share/icons/hicolor/128x128/apps/${_pkgbasename}.png"