summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTom Ingleby2015-06-10 15:06:45 +0100
committerTom Ingleby2015-06-10 15:06:45 +0100
commitf6c59f2f29505ba541771a821604735bb4a1dedc (patch)
treed56751f3a39910aa9fc4cd0c0de0517d4d25abb6 /PKGBUILD
downloadaur-f6c59f2f29505ba541771a821604735bb4a1dedc.tar.gz
mraa: initial import and update to v0.7.2
Signed-off-by: Tom Ingleby <tom@ewsting.org>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0dce5635ed5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Tom Ingleby <tom@ewsting.org>
+pkgname='mraa'
+pkgver=0.7.2
+pkgrel=0
+pkgdesc="Low Level Skeleton Library for IO Communication on GNU/Linux platforms."
+makedepends=('git' 'cmake' 'swig')
+optdepends=('python: for Python support')
+url="https://github.com/intel-iot-devkit/mraa"
+license=('MIT')
+arch=('x86_64' 'i686')
+
+source=("https://github.com/intel-iot-devkit/mraa/archive/v0.7.2.tar.gz")
+md5sums=('ad04bdfe35cede82256155261ccd400b')
+
+build() {
+ mkdir -p mraa-$pkgver/build
+ cd mraa-$pkgver/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DBUILDSWIGNODE=off ../
+ make
+}
+
+package() {
+ cd $srcdir/mraa-$pkgver/build
+ make DESTDIR="${pkgdir}/" install
+}
+