summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 07:15:01 -0600
committerBrian Bidulock2015-06-10 07:15:01 -0600
commit0d5c300bb0dd1d8bceea43eb608d2226b0963658 (patch)
tree72e4be13709d7bba47e7b1910b2978125a8c173a /PKGBUILD
downloadaur-0d5c300bb0dd1d8bceea43eb608d2226b0963658.tar.gz
initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd6be0f5e6b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=mrouted
+pkgver=3.9.6
+pkgrel=7
+pkgdesc="mrouted is an implementation of the DVMRP multicast routing protocol. It turns a UNIX workstation into a DVMRP multicast router with tunnel support, in order to cross non-multicast-aware routers."
+arch=('i686' 'x86_64')
+url="http://freshmeat.net/projects/mrouted"
+license=('BSD')
+backup=('etc/mrouted.conf')
+source=("http://cloud.github.com/downloads/troglobit/mrouted/mrouted-${pkgver}.tar.bz2"
+ "mrouted.service")
+md5sums=('e88dfa6a99dd4ee7d8bc7b2dca87ca9e'
+ 'a1ba2643cb169513666a2dcc98e01f4e')
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}/"
+ # and this was supposed to be "easier"?
+ sed -i 's|sbin|bin|g' Makefile
+
+ make || return 1
+}
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}/"
+ make prefix=/usr DESTDIR=$pkgdir install || return 1
+ install -Dm644 $srcdir/mrouted.service "$pkgdir/usr/lib/systemd/system/mrouted.service"
+ # and this was supposed to be "easier"?
+ mv "$pkgdir/usr/bin/mtrace" "$pkgdir/usr/bin/mrtrace"
+ mv "$pkgdir/usr/share/man/man8/mtrace.8" "$pkgdir/usr/share/man/man8/mrtrace.8"
+}