summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoost Molenaar2021-01-19 10:45:55 +0100
committerJoost Molenaar2021-01-19 10:51:59 +0100
commit1d74f5ca59cfe8ca296f46f359f82cfdb0092e32 (patch)
treeb1a665cb736b6c774a4676ec9e5529b3c40dc444 /PKGBUILD
parent698c0deb20a40445a002991bd45aad324e972397 (diff)
downloadaur-1d74f5ca59cfe8ca296f46f359f82cfdb0092e32.tar.gz
Use upstream systemd service file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 40377f6dc73d..952966c92032 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,14 +9,12 @@ arch=('i686' 'x86_64')
url="https://github.com/troglobit/mrouted"
license=('BSD')
depends=('glibc')
-source=("https://github.com/troglobit/mrouted/releases/download/${pkgver}/mrouted-${pkgver}.tar.gz"
- "mrouted.service")
-md5sums=('b921f9e152e039efdac745438ef8362c'
- 'a1ba2643cb169513666a2dcc98e01f4e')
+source=("https://github.com/troglobit/mrouted/releases/download/${pkgver}/mrouted-${pkgver}.tar.gz")
+md5sums=('b921f9e152e039efdac745438ef8362c')
prepare() {
cd $pkgname-$pkgver
- ./configure --prefix=/usr --sbindir=/usr/bin
+ ./configure --prefix=/usr --sbindir=/usr/bin --with-systemd=/usr/lib/systemd/system
}
build() {
@@ -26,7 +24,6 @@ build() {
package() {
cd $pkgname-$pkgver
make DESTDIR=$pkgdir install
- install -Dm644 "$srcdir/mrouted.service" "$pkgdir/usr/lib/systemd/system/mrouted.service"
# and this was supposed to be "easier"?
mv "$pkgdir/usr/bin/mtrace" "$pkgdir/usr/bin/mrtrace"
mv "$pkgdir/usr/share/man/man8/mtrace.8" "$pkgdir/usr/share/man/man8/mrtrace.8"