summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrian Bidulock2017-03-30 22:48:14 -0600
committerBrian Bidulock2017-03-30 22:48:14 -0600
commit47a0f5bc05f13e275a50cd07c7755697258c11f8 (patch)
tree7b4e9624a65ec8758dcff4c8b1f4d7c092a36e99 /PKGBUILD
parentdd92953a74bf1172498be5f28c3bf08e5d62ebd9 (diff)
downloadaur-47a0f5bc05f13e275a50cd07c7755697258c11f8.tar.gz
version 3.9.8-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 25 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dd6be0f5e6b9..e2a3b16ee482 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,36 @@
pkgname=mrouted
-pkgver=3.9.6
-pkgrel=7
-pkgdesc="mrouted is an implementation of the DVMRP multicast routing protocol. It turns a UNIX workstation into a DVMRP multicast router with tunnel support, in order to cross non-multicast-aware routers."
+pkgver=3.9.8
+pkgrel=1
+pkgdesc="An implementation of the DVMRP multicast routing protocol. It turns a UNIX workstation into a DVMRP multicast router with tunnel support, in order to cross non-multicast-aware routers."
arch=('i686' 'x86_64')
-url="http://freshmeat.net/projects/mrouted"
+url="https://github.com/troglobit/mrouted"
license=('BSD')
backup=('etc/mrouted.conf')
-source=("http://cloud.github.com/downloads/troglobit/mrouted/mrouted-${pkgver}.tar.bz2"
+depends=('glibc')
+source=("https://github.com/troglobit/mrouted/releases/download/${pkgver}/mrouted-${pkgver}.tar.bz2"
"mrouted.service")
-md5sums=('e88dfa6a99dd4ee7d8bc7b2dca87ca9e'
+md5sums=('8fdd21cf7028b0d16e9477140d311750'
'a1ba2643cb169513666a2dcc98e01f4e')
-build() {
- cd "$srcdir/${pkgname}-${pkgver}/"
- # and this was supposed to be "easier"?
- sed -i 's|sbin|bin|g' Makefile
+prepare() {
+ cd $pkgname-$pkgver
+ ./configure
+}
- make || return 1
+build() {
+ cd $pkgname-$pkgver
+ # and this was supposed to be "easier"?
+ sed -i 's|sbin|bin|g' Makefile
+ make
}
package() {
- cd "$srcdir/${pkgname}-${pkgver}/"
- make prefix=/usr DESTDIR=$pkgdir install || return 1
- install -Dm644 $srcdir/mrouted.service "$pkgdir/usr/lib/systemd/system/mrouted.service"
- # and this was supposed to be "easier"?
- mv "$pkgdir/usr/bin/mtrace" "$pkgdir/usr/bin/mrtrace"
- mv "$pkgdir/usr/share/man/man8/mtrace.8" "$pkgdir/usr/share/man/man8/mrtrace.8"
+ cd $pkgname-$pkgver
+ make prefix=/usr DESTDIR=$pkgdir install
+ install -Dm644 "$srcdir/mrouted.service" "$pkgdir/usr/lib/systemd/system/mrouted.service"
+ # and this was supposed to be "easier"?
+ mv "$pkgdir/usr/bin/mtrace" "$pkgdir/usr/bin/mrtrace"
+ mv "$pkgdir/usr/share/man/man8/mtrace.8" "$pkgdir/usr/share/man/man8/mrtrace.8"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
+
+# vim: se sw=2 et: