summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAinola2015-08-08 12:33:10 -0600
committerAinola2015-08-08 12:33:10 -0600
commit872292f7bc98874626652a78379e34ab6d36928a (patch)
tree8dba7249e9f6ecbce49e63ef0bab948c0fc2f8d5 /PKGBUILD
downloadaur-872292f7bc98874626652a78379e34ab6d36928a.tar.gz
initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49a18bc6f401
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Ainola
+# Contributor: Pio
+
+pkgname=mrrescue
+pkgver=1.02c
+pkgrel=1
+pkgdesc="An arcade styled 2d action game centered around evacuating civilians from burning buildings."
+arch=('any')
+url="http://tangramgames.dk/games/mrrescue/"
+license=('CCPL:by-sa' 'zlib')
+depends=('love')
+makedepends=('gendesk')
+source=("https://github.com/SimonLarsen/mrrescue/releases/download/v${pkgver}/${pkgname}-${pkgver}.love")
+md5sums=('85897f04f2e9c3aaded74bf178aeab4c')
+
+build() {
+ # Generate desktop file
+ cd "${srcdir}"
+ gendesk -n
+
+ # Generate run script
+ echo "love /usr/share/mrrescue/mrrescue-${pkgver}.love" > "${pkgname}.sh"
+}
+
+package() {
+ # Copy game and license
+ cd "${srcdir}" #/${pkgname}-${pkgver}-love"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${pkgname}-${pkgver}.love" "${pkgdir}/usr/share/${pkgname}/${pkgname}-${pkgver}.love"
+ # Extract an image to be used as icon
+ unzip -p "${pkgname}-${pkgver}.love" data/splash.png > mrrescue.png
+ # Copy desktop file, icon and run script
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -D "${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+}