summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDario Bosch2018-04-06 12:16:46 +0200
committerDario Bosch2018-04-06 12:16:46 +0200
commita7a62e490df1b0f51009c7f12746ecd1bcab570e (patch)
treea75de6280ccd8e5731f313d67a14a0196cd7d621 /PKGBUILD
downloadaur-a7a62e490df1b0f51009c7f12746ecd1bcab570e.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb94e58b1cba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Dario Bosch <LastnameFirstname at gmail dot com>
+
+pkgname=mrtrix3
+pkgver=r6677.fce21191
+pkgrel=1
+pkgdesc="tools for diffusion MRI analyses, data conversion and a viewer (mrview)"
+arch=('x86_64')
+url="https://github.com/MRtrix3/${pkgname}"
+license=('MPL2')
+
+depends=(
+ # 'zlib' # already installed as dependency of python
+ # 'qt5-base' # already installed as dependency of qt5-svg
+ 'qt5-svg'
+ 'python'
+ )
+
+optdepends=(
+ 'libtiff'
+ 'fftw'
+ )
+
+makedepends=(
+ 'gcc'
+ 'git'
+ 'eigen'
+)
+
+provides=('mrtrix3')
+conflicts=('mrtrix3')
+
+source=("${pkgname}-git::git+https://github.com/MRtrix3/${pkgname}#commit=$(cut -d'.' -f2 <<< ${pkgver})")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname}-git"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ # Set CPU architecture to the building system's architecture
+ export ARCH=native
+ cd "${pkgname}-git"
+ ./configure
+ ./build
+}
+
+package() {
+ cd "${pkgname}-git"
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/lib"
+ cp -R ./bin/* "$pkgdir/usr/bin"
+ cp -R ./lib/* "$pkgdir/usr/lib"
+ chmod -R 755 "$pkgdir/usr/bin"
+ chmod -R 755 "$pkgdir/usr/lib"
+}