summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnatol Pomozov2015-06-17 08:49:27 -0700
committerAnatol Pomozov2015-06-17 08:49:27 -0700
commit1153425ae8fe4d3178546bb7dccc05ac1ccc7a9a (patch)
tree41716d1739da4c6bc7a15d671cf3c6fd730bae35 /PKGBUILD
downloadaur-1153425ae8fe4d3178546bb7dccc05ac1ccc7a9a.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c779d13f2c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
+
+pkgname=mruby
+pkgver=1.1.0
+pkgrel=1
+pkgdesc='Lightweight Ruby'
+arch=(i686 x86_64)
+url='https://github.com/mruby/mruby'
+license=(MIT)
+makedepends=(git bison ruby)
+options=(staticlibs)
+source=(https://github.com/mruby/mruby/archive/$pkgver.zip
+ remove_termcap_static_lib.patch)
+sha1sums=('SKIP'
+ '3042fc7811afee7e88535dca43495a1a5486d6a5')
+
+prepare() {
+ cd mruby-$pkgver
+ patch -p1 < "$srcdir"/remove_termcap_static_lib.patch
+}
+
+build() {
+ cd mruby-$pkgver
+ CFLAGS="$CFLAGS -std=c11"
+ make
+}
+
+check() {
+ cd mruby-$pkgver
+ make test
+}
+
+package() {
+ cd mruby-$pkgver
+
+ install -d "$pkgdir/usr/bin" "$pkgdir/usr/lib"
+ cp build/host/bin/* "$pkgdir/usr/bin"
+ cp build/host/lib/*.a "$pkgdir/usr/lib"
+ cp -r include "$pkgdir/usr"
+}
+