summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnatol Pomozov2015-11-19 09:58:56 -0800
committerAnatol Pomozov2015-11-19 09:58:56 -0800
commit1bb9a9a33257cf5fb2c94b8432fb08311fe416c3 (patch)
tree4593be63a92ed4b4c4496289766e03fc95a2121e /PKGBUILD
parent1153425ae8fe4d3178546bb7dccc05ac1ccc7a9a (diff)
downloadaur-1bb9a9a33257cf5fb2c94b8432fb08311fe416c3.tar.gz
updpkg
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 7 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6c779d13f2c9..2f48aa29ad57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,17 @@
# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
pkgname=mruby
-pkgver=1.1.0
+pkgver=1.2.0
pkgrel=1
pkgdesc='Lightweight Ruby'
arch=(i686 x86_64)
url='https://github.com/mruby/mruby'
license=(MIT)
+depends=(readline)
makedepends=(git bison ruby)
options=(staticlibs)
-source=(https://github.com/mruby/mruby/archive/$pkgver.zip
- remove_termcap_static_lib.patch)
-sha1sums=('SKIP'
- '3042fc7811afee7e88535dca43495a1a5486d6a5')
-
-prepare() {
- cd mruby-$pkgver
- patch -p1 < "$srcdir"/remove_termcap_static_lib.patch
-}
+source=(mruby-$pkgver.zip::https://github.com/mruby/mruby/archive/$pkgver.zip)
+sha1sums=('0f3c535d6c89b710d1fd0fdbf167077abce55996')
build() {
cd mruby-$pkgver
@@ -33,9 +27,11 @@ check() {
package() {
cd mruby-$pkgver
- install -d "$pkgdir/usr/bin" "$pkgdir/usr/lib"
+ install -d "$pkgdir/usr/bin" "$pkgdir/usr/lib" "$pkgdir/usr/share/licenses/mruby"
cp build/host/bin/* "$pkgdir/usr/bin"
cp build/host/lib/*.a "$pkgdir/usr/lib"
cp -r include "$pkgdir/usr"
+
+ cp MITL "$pkgdir/usr/share/licenses/mruby/LICENSE"
}