summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Maunier2019-04-17 15:22:43 +0200
committerFlorian Maunier2019-04-17 15:22:43 +0200
commite968d46b9d7066badaf86cd8b2de085ca0098be4 (patch)
treea1c7027b0d5872bae3f46367ab247268721b14b8 /PKGBUILD
downloadaur-e968d46b9d7066badaf86cd8b2de085ca0098be4.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..579fd9ee7fe3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Florian Maunier <fmauneko@dissidence.ovh>
+# Contributor: jtmb <packaging at technologicalwizardry dot com>
+pkgname=msbuild
+pkgver=16.0+xamarinxplat.2019.04.08.19.19
+pkgrel=1
+pkgdesc="Xamarin implementation of the Microsoft build system"
+arch=('x86_64')
+depends=('mono>=5.0.0')
+makedepends=('libcurl-gnutls')
+provides=('msbuild')
+conflicts=('msbuild')
+url="https://github.com/mono/msbuild"
+license=('MIT')
+source=("https://download.mono-project.com/sources/msbuild/msbuild-${pkgver}.tar.xz"
+ 'fix-install.patch')
+sha256sums=('0d425603281ae84d3cf560ea4f9e2b2159e7764f71406035070a7fe27878ec49'
+ '8780925e01d4e5bdf8f93c439fe92da7a64f14099b60382499b477a512b56dca')
+
+prepare() {
+ cd "${pkgname}-${pkgver%+*}"
+ patch --forward --strip=1 --input="${srcdir}/fix-install.patch"
+}
+
+package() {
+ cd "${pkgname}-${pkgver%+*}"
+ make
+ ./install-mono-prefix.sh "/usr" /p:StagingDir="${pkgdir}/usr" /p:TargetMSBuildToolsVersion="15.0"
+}