summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F. Rødseth2018-10-17 12:00:22 +0200
committerAlexander F. Rødseth2018-10-17 12:00:22 +0200
commitf54e42461f8b0b074c74f737e93e2b1fffa996ef (patch)
tree28a9f236fc9506aea9adb78333e112882750660c /PKGBUILD
downloadaur-f54e42461f8b0b074c74f737e93e2b1fffa996ef.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e6f819a10f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=msg2
+pkgver=1.0.1
+pkgrel=1
+pkgdesc='Output a blue arrow and a white message'
+arch=('x86_64')
+url="https://roboticoverlords.org/msg2"
+license=('GPL')
+makedepends=('cmake' 'ninja')
+source=("https://roboticoverlords.org/$pkgname/$pkgname-$pkgver.tar.xz")
+sha256sums=('cd70e516723f47a371f8f89e16f40309b618b36d614bb8fec7644559ad328671')
+
+build() {
+ mkdir -p build
+ cd build
+ cmake "$srcdir/$pkgname-$pkgver" -GNinja
+ ninja
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+ install -Dm644 "$pkgname-$pkgver/$pkgname.1" \
+ "$pkgdir/usr/share/man/man1/$pkgname.1"
+}
+
+# vim: ts=2 sw=2 et:
+