summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicholas Fraser2016-05-29 15:23:17 -0400
committerNicholas Fraser2016-05-29 15:23:17 -0400
commit56687cbafa431fa83ccfec1c34eb635da576b657 (patch)
tree3cd585de9706d79c093b56d954c451d7a5d41320 /PKGBUILD
downloadaur-56687cbafa431fa83ccfec1c34eb635da576b657.tar.gz
Initial PKGBUILD, msgpack-tools version 0.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f20a69f52a1b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Nicholas Fraser <nicholas.rd.fraser@gmail.com>
+pkgname=msgpack-tools
+pkgver=0.4
+pkgrel=1
+pkgdesc="Command-line tools for converting between MessagePack and JSON"
+arch=('i686' 'x86_64' 'mips64el' 'armv6h' 'armv7h' 'arm' 'aarch64')
+url="https://github.com/ludocode/msgpack-tools"
+license=('MIT')
+depends=('gcc-libs')
+makedepends=('cmake')
+source=(https://github.com/ludocode/msgpack-tools/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz)
+sha256sums=('6ca77477ed47ccf4ac882ace3ee5f33a7bc7b929d12c5f10fa0c8fb5874fbc10')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}