summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-01-08 09:20:38 -0500
committerCarlos Aznarán Laos2022-01-08 09:20:38 -0500
commitf98aa1961e2da1367c9a159234c0717d0bfd557f (patch)
treeb16540577240f58ce20106808e94d718a6e80039 /PKGBUILD
parentb19020c1962aa8141dbcfc586a455bbcb93f11e0 (diff)
downloadaur-f98aa1961e2da1367c9a159234c0717d0bfd557f.tar.gz
Version bump to 20200924
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD67
1 files changed, 36 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a63f6961c060..b43e6378b6d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,49 @@
-# Maintainer: Lucas H. Gabrielli <heitzmann@gmail.com>
-
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Lucas H. Gabrielli <heitzmann@gmail.com>
_base=mshr
-_fragment="#branch=master"
pkgname=${_base}-git
-pkgdesc="Mesh generation component of FEniCS"
-pkgver=20180104
+pkgdesc="Mesh generation component of FEniCS (git version)"
+pkgver=20200924
pkgrel=1
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://bitbucket.org/fenics-project/${_base}"
-license=('GPL3')
-groups=('fenics-git')
-depends=('python-dolfin-git' 'mpfr')
-makedepends=('git')
-options=(!emptydirs)
-source=("${_base}::git+https://bitbucket.org/fenics-project/${_base}.git${_fragment}")
-md5sums=('SKIP')
+license=(GPL3)
+depends=(dolfin mpfr tetgen) # cgal
+makedepends=(cmake git)
+# options=(!emptydirs)
+source=(git+${url}.git#branch=master)
+sha512sums=('SKIP')
pkgver() {
- cd ${_base}
- git log --format="%cd" --date=short -1 | sed 's/-//g'
+ cd ${_base}
+ git log --format="%cd" --date=short -1 | sed 's/-//g'
}
-
+# -DCMAKE_SKIP_BUILD_RPATH:BOOL=ON \
+# -DUSE_SYSTEM_CGAL:BOOL=ON \
build() {
- cd ${_base}
- [ -d build ] && rm -rf build
- mkdir build
- cd build
-
- cmake .. \
- -DCMAKE_INSTALL_PREFIX="${pkg}"/usr \
- -DCMAKE_SKIP_BUILD_RPATH=TRUE \
- -DCMAKE_SKIP_RPATH=TRUE \
- -DCMAKE_BUILD_TYPE="Release"
+ cmake \
+ -S ${_base} \
+ -B build \
+ -DCMAKE_BUILD_TYPE:STRING=None \
+ -DCMAKE_INSTALL_PREFIX="${pkg}"/usr \
+ -DBUILD_SHARED_LIBS:BOOL=ON \
+ -DCMAKE_SKIP_RPATH:BOOL=ON \
+ -DCMAKE_INSTALL_RPATH_USE_LINK_PATH:BOOL=OFF \
+ -DUSE_SYSTEM_TETGEN:BOOL=ON \
+ -DENABLE_TESTS:BOOL=ON \
+ -DENABLE_MSHRABLE:BOOL=ON \
+ -Wno-dev
+ cmake --build build --target all
+}
- make
+check() {
+ if [ -z $(ldconfig -p | grep libcuda.so.1) ]; then
+ export OMPI_MCA_opal_warn_on_missing_libcuda=0
+ fi
+ LD_LIBRARY_PATH="$LD_LIBRARY_PATH:${srcdir}/build" ctest -E "^Python-*" --test-dir build
}
package() {
- cd ${_base}/build
- make install DESTDIR="${pkgdir}"
+ DESTDIR="${pkgdir}" cmake --build build --target install
+ install -Dm 644 ${_base}/COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
-
-# vim: shiftwidth=2 softtabstop=2 tabstop=2 noexpandtab