summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZhuoyun Wei2023-12-22 17:33:04 -0800
committerZhuoyun Wei2023-12-22 17:33:24 -0800
commitb1e32c11f7cff0a87a829223212c4c82171cde9e (patch)
tree3a00f2d7a9fa4ef44dc7f9667e66e56daf6a8f4d /PKGBUILD
parent0738da2a810560106ce5b83b1e43a600ac791145 (diff)
downloadaur-msmtp-ntlm.tar.gz
Bump to 1.8.25 with overhaul
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 23 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4a22aba9288b..daac9a4d9025 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,44 @@
# Maintainer: Zhuoyun Wei <wzyboy@wzyboy.org>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: T.J. Townsend <blakkheim@archlinux.org
# Contributor: Eric BĂ©langer <eric@archlinux.org>
pkgname=msmtp-ntlm
_pkgname=msmtp
-pkgver=1.6.3
+pkgver=1.8.25
pkgrel=1
pkgdesc="A mini smtp client - NTLM support"
-arch=('i686' 'x86_64')
-url="http://msmtp.sourceforge.net"
+arch=('x86_64')
+url="https://marlam.de/msmtp/"
license=('GPL3')
-makedepends=('texlive-plainextra' 'gsasl-ntlm' 'libsecret')
+makedepends=('libsecret' 'gsasl-ntlm' 'texlive-plaingeneric')
+optdepends=('netcat: for included msmtpq script')
provides=('msmtp')
conflicts=('msmtp')
-source=(http://download.sourceforge.net/sourceforge/msmtp/${_pkgname}-${pkgver}.tar.xz)
+source=("https://marlam.de/msmtp/releases/msmtp-$pkgver.tar.xz")
install=msmtp.install
-sha256sums=('f982be069c0772c3ee83925f552f5dac5fb307d2d1c68202f9926bb13b757355')
+sha256sums=('2dfe1dbbb397d26fe0b0b6b2e9cd2efdf9d72dd42d18e70d7f363ada2652d738')
build() {
- cd ${_pkgname}-${pkgver}
- ./configure --prefix=/usr --sysconfdir=/etc --with-ssl=gnutls --with-libgsasl
+ cd $_pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc --with-libgsasl
make
make -C doc html pdf
}
package() {
- cd ${_pkgname}-${pkgver}
- make DESTDIR="${pkgdir}" install
- make DESTDIR="${pkgdir}" -C doc install-html install-pdf
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" -C doc install-html install-pdf
-# Installing example configs and scripts to /usr/share/doc/msmtp
-# as they are not installed by default (Debian and Gentoo do it this way)
- install -d "${pkgdir}/usr/share/doc/msmtp"
- cp -r scripts/{find_alias,msmtpqueue,msmtpq,set_sendmail} "${pkgdir}/usr/share/doc/msmtp/"
- install -D -m644 doc/*.example "${pkgdir}/usr/share/doc/msmtp/"
+ # Installing example configs and scripts to /usr/share/doc/msmtp
+ # as they are not installed by default (Debian and Gentoo do it this way)
+ install -d "$pkgdir"/usr/share/doc/msmtp
+ cp -r scripts/{find_alias,msmtpqueue,msmtpq,set_sendmail} "$pkgdir"/usr/share/doc/msmtp/
+ install -D -m644 doc/*.example "$pkgdir"/usr/share/doc/msmtp/
- install -D -m644 scripts/vim/msmtp.vim "${pkgdir}/usr/share/vim/vimfiles/syntax/msmtp.vim"
+ install -D -m644 scripts/vim/msmtp.vim "$pkgdir"/usr/share/vim/vimfiles/syntax/msmtp.vim
+
+ chmod 755 "$pkgdir"/usr/share/doc/msmtp/{find_alias,msmtpqueue,set_sendmail}/*.sh
+ chmod 755 "$pkgdir"/usr/share/doc/msmtp/msmtpq/msmtp*
}