summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZhuoyun Wei2016-02-03 11:51:44 +0800
committerZhuoyun Wei2016-02-03 11:51:44 +0800
commit0738da2a810560106ce5b83b1e43a600ac791145 (patch)
tree133835aa2a12c21467fa64656c9d976359a2a00c /PKGBUILD
downloadaur-0738da2a810560106ce5b83b1e43a600ac791145.tar.gz
Genesis commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a22aba9288b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Zhuoyun Wei <wzyboy@wzyboy.org>
+# Contributor: Eric BĂ©langer <eric@archlinux.org>
+
+pkgname=msmtp-ntlm
+_pkgname=msmtp
+pkgver=1.6.3
+pkgrel=1
+pkgdesc="A mini smtp client - NTLM support"
+arch=('i686' 'x86_64')
+url="http://msmtp.sourceforge.net"
+license=('GPL3')
+makedepends=('texlive-plainextra' 'gsasl-ntlm' 'libsecret')
+provides=('msmtp')
+conflicts=('msmtp')
+source=(http://download.sourceforge.net/sourceforge/msmtp/${_pkgname}-${pkgver}.tar.xz)
+install=msmtp.install
+sha256sums=('f982be069c0772c3ee83925f552f5dac5fb307d2d1c68202f9926bb13b757355')
+
+build() {
+ cd ${_pkgname}-${pkgver}
+ ./configure --prefix=/usr --sysconfdir=/etc --with-ssl=gnutls --with-libgsasl
+ make
+ make -C doc html pdf
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}" -C doc install-html install-pdf
+
+# Installing example configs and scripts to /usr/share/doc/msmtp
+# as they are not installed by default (Debian and Gentoo do it this way)
+ install -d "${pkgdir}/usr/share/doc/msmtp"
+ cp -r scripts/{find_alias,msmtpqueue,msmtpq,set_sendmail} "${pkgdir}/usr/share/doc/msmtp/"
+ install -D -m644 doc/*.example "${pkgdir}/usr/share/doc/msmtp/"
+
+ install -D -m644 scripts/vim/msmtp.vim "${pkgdir}/usr/share/vim/vimfiles/syntax/msmtp.vim"
+}