summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorvonPalitroque2018-05-14 11:39:29 -0400
committervonPalitroque2018-05-14 11:39:29 -0400
commit1f6f6d52dd2c86126100d8a4a4db9db1aaffee08 (patch)
treec034dcee65c3463bb2980d910cfaed32a0ed6dbf /PKGBUILD
parent6f4117487ec8dc76a79492519637e0b2aafa18e1 (diff)
downloadaur-1f6f6d52dd2c86126100d8a4a4db9db1aaffee08.tar.gz
Updated to latest version.
Updated to latest upstream version.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 5 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 47b489b045a1..dc9137ec1bc7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_target="msp430-elf"
pkgname=${_target}-gcc
-pkgver=7.3.0
-_islver=0.18
+pkgver=8.1.0
+_islver=0.19
pkgrel=1
pkgdesc="The GNU Compiler Collection for the ${_target} target."
arch=(i686 x86_64)
@@ -15,15 +15,9 @@ conflicts=("${_target}-gcc-stage1")
replaces=("${_target}-gcc-stage1")
provides=("${_target}-gcc-stage1")
source=(http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2
- ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.xz
- fix-pr79242.patch
- 0001-MSP430-Dont-specifically-set-TYPE_SIZE-for-__intN-ty.patch
- msp430-disable-delete-null-pointer-check.patch)
-sha256sums=('6b8b0fd7f81d0a957beb3679c81bbb34ccc7568d5682844d8924424a0dadcb1b'
- '832ca6ae04636adbb430e865a1451adf6979ab44ca1c8374f61fba65645ce15c'
- '14dcf8903684634f02da4d9bf73f9d93e39db9c07e0e1d2d7d997b5489bc5ada'
- '12939e5ba47deecae8c182ad097f7a118c7b70461803b7403b636a18117201f4'
- 'ade2f8f510d7ad76b1672644489ed0bef82593b31474c4c8bd159edea8ef6eef')
+ ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.xz)
+sha256sums=('d59726f34f7852a081fbd3defd1ab2136f174110fc2e0c8d10bb122173fa9ed8'
+ '1d1866f992626e61349a1ccd0b8d5253816222cdc13390dcfaa74b093aa2b153')
prepare() {
@@ -33,14 +27,6 @@ prepare() {
[[ -d gcc-build ]] && rm -rf gcc-build
mkdir gcc-build
-
- patch -p1 < ../msp430-disable-delete-null-pointer-check.patch
- # Preliminary fix for pr79242. Without this newlib fails to compile for
- # MSP430X cores with an ICE. The patch has been around in the GCC mailing
- # list for a while, not sure why it has not been added to trunk.
- patch -p1 < ../fix-pr79242.patch
- # while we are at it, fix pr78849
- patch -p1 < ../0001-MSP430-Dont-specifically-set-TYPE_SIZE-for-__intN-ty.patch
}
build() {