summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorvonPalitroque2017-07-26 15:45:54 -0400
committervonPalitroque2017-07-26 15:45:54 -0400
commit08e820f4476ad19652d533f25e4df4cc7b5fd14d (patch)
tree86efb44e63b8ea089185eaa1c362efe1202626a4 /PKGBUILD
parent8c76f9e57d594190009e0226c5f039523438d6ac (diff)
downloadaur-08e820f4476ad19652d533f25e4df4cc7b5fd14d.tar.gz
Updated to latest version.
Updated to latest upstream version. Small caveat: The bug described in pr79242 is still not resolved and activity on it seems to be of low interest. Unfortunately, I do not have the time to look into it that much. As such, instead of delaying the update until the bug is resolved, I have opted to instead revert the change that exposed the bug [2]. Yes, this means that the bug is still there and may be triggered a different way, I have yet to find a scenario where it happens though. I will ask then the community: if such case is found, please let me know and/or add it to [1]. I will then prepare and release a PKGBUILD based on gcc 6.4 instead. Cheers, Orlando. [1] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=79242 [2] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=71289
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9b7db66443bc..07e1ee55aedd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_target="msp430-elf"
pkgname=${_target}-gcc-stage1
-pkgver=6.3.0
+pkgver=7.1.0
_islver=0.18
pkgrel=1
pkgdesc="The GNU Compiler Collection bootstrap for the ${_target} target."
@@ -11,12 +11,14 @@ license=('GPL' 'LGPL')
url="http://gcc.gnu.org"
depends=("${_target}-binutils>=2.25" 'libmpc' 'elfutils')
options=('staticlibs' '!buildflags' '!libtool' '!emptydirs' 'zipman' 'docs' '!strip')
-source=(ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
- http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2
- fix-insn-delay_cycles_32x.patch)
-sha256sums=('f06ae7f3f790fbf0f018f6d40e844451e6bc3b7bc96e128e63b09825c1f8b29f'
- '6b8b0fd7f81d0a957beb3679c81bbb34ccc7568d5682844d8924424a0dadcb1b'
- '0cd87771d1fd8ec5d0c413ae8c18b9b2599f2c66a0fa8b5fd4aa2f01ac1b5f86')
+source=(http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2
+ 0001-Use-GET_MODE_BITSIZE-when-setting-TYPE_SIZE.patch
+ revert-pr71289.patch
+ ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2)
+sha256sums=('6b8b0fd7f81d0a957beb3679c81bbb34ccc7568d5682844d8924424a0dadcb1b'
+ '28f39dd3ef931d87de1eccf7700406c5b76fa7a6ecf47cfb3f199b33cd1fdf02'
+ '836ecb799c88b1c4db7e6ef2df72437a8fe162d1a2d3fb395198fba702f7d9d6'
+ '8a8136c235f64c6fef69cac0d73a46a1a09bb250776a050aec8f9fc880bebc17')
prepare() {
# add isl into tree
@@ -24,12 +26,16 @@ prepare() {
[[ -L isl ]] && rm -f isl
ln -s ../isl-${_islver} isl
- # this did not make it into 6.3.0 for some reason
- patch -p1 < ../fix-insn-delay_cycles_32x.patch
-
# clean build directory
[[ -d gcc-build ]] && rm -rf gcc-build
mkdir gcc-build
+
+ # Until pr79242 is resolved, revert pr71289. Yes, the underlying bug is still
+ # there, but I do not have the time to investigate it and fix it at the
+ # moment. Patches/comments are welcome.
+ patch -p1 < ../revert-pr71289.patch
+ # while we are at it, fix pr78849
+ patch -p1 < ../0001-Use-GET_MODE_BITSIZE-when-setting-TYPE_SIZE.patch
}
build() {