summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFran Dieguez2015-11-21 00:16:42 +0100
committerFran Dieguez2015-11-21 00:16:42 +0100
commiteda9970de1d99a48c5cddb2271d098876842a450 (patch)
treeed6311a3c8c0b5eb1616d1644ffab13c7f74a0c7 /PKGBUILD
downloadaur-eda9970de1d99a48c5cddb2271d098876842a450.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef750624d9a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Fran Dieguez <fran dot dieguez at mabishu dot com>
+pkgname=mssh-git
+pkgver=2.2.r0.g9221061
+pkgrel=1
+pkgdesc="Tool to administrate multiple servers at once"
+arch=('x86_64' 'i686')
+license=('BSD')
+url="http://baloo.dyndns.biz/"
+options=('!strip')
+makedepends=("git" "bash-completion" "gconf" "intltool")
+depends=("gconf" "openssh" "vte3")
+conflicts=("mssh")
+provides=("mssh=$pkgver")
+source=("$pkgname::git://baloo.dyndns.biz/mssh.git")
+sha256sums=('SKIP')
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/[_-]/./g'
+}
+build() {
+ cd $pkgname
+ ./bootstrap.sh
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --with-gconf-schema-file-dir=/usr/share/gconf/schemas \
+ --disable-nls
+ make
+}
+check() {
+ cd $pkgname
+ make -k check
+}
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}