summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantin Shalygin2023-10-02 14:51:15 +0700
committerKonstantin Shalygin2023-10-02 14:51:15 +0700
commita42ab7dfb4231ccfff72b0beec83139d44063d5f (patch)
treeacb17e72193aa1f98ba6d9c1c10ecf8999b013b1 /PKGBUILD
parent1f7020a37e37597840e1eb6922079205c3f390a3 (diff)
downloadaur-a42ab7dfb4231ccfff72b0beec83139d44063d5f.tar.gz
Bump to 4.25.0.1 & added support for fw-mgr
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ab53b4b56ca..37482e5f518b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,19 @@
# Contributor: Konstantin Shalygin <k0ste@k0ste.ru>
pkgname='mstflint'
-pkgver='4.24.0.1'
-_pkgver='4.24.0-1'
+pkgver='4.25.0.1'
+_pkgver='4.25.0-1'
pkgrel='1'
pkgdesc='Mstflint - an open source version of MFT (Mellanox Firmware Tools)'
arch=('x86_64' 'aarch64')
url="https://github.com/Mellanox/${pkgname}"
license=('GPL2' 'custom:"OpenIB.org BSD"')
-depends=('python' 'iniparser')
-makedepends=('rdma-core')
+depends=('python' 'iniparser' 'openssl' 'libxml2' 'libidn2' 'libpsl'
+ 'libunistring' 'zlib' 'xz' 'boost-libs' 'icu' 'keyutils' 'brotli'
+ 'jsoncpp' 'curl' 'libnghttp2')
+makedepends=('rdma-core' 'boost' 'openssl')
source=("${url}/archive/v${_pkgver}/${pkgname}-${_pkgver}.tar.gz")
-sha256sums=('a30e422eac3a163b2a8740ba5c941ba93c8788731ae7363e7beea6adc0f0bcc7')
+sha256sums=('46f5fda9c8687bbcdae62145c17ad70f6b1725d738985eb3c8efd8c71604ddc3')
prepare() {
cd "${pkgname}-${_pkgver}"
@@ -25,7 +27,8 @@ prepare() {
--sbindir="/usr/bin" \
--libexecdir="/usr/lib" \
--sysconfdir="/etc" \
- --localstatedir="/var/${pkgname}"
+ --localstatedir="/var/${pkgname}" \
+ --enable-fw-mgr
}
build() {