summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2017-11-05 02:34:43 +0100
committerFabioLolix2017-11-05 02:34:43 +0100
commit97f244313e2bf755cf32e1dd3b812bfa6b9888b5 (patch)
treecdf3a0dc442dab18656716082f1beffc17a82d11 /PKGBUILD
downloadaur-97f244313e2bf755cf32e1dd3b812bfa6b9888b5.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ffb24c9f7c0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Fabio Loli <loli_fabio@protonmail.com> -> https://github.com/FabioLolix
+
+pkgname=mstreamexpress-bin
+pkgver=0.4.3
+pkgrel=1
+pkgdesc="Music streaming server with Flac support, based on Electron"
+arch=('x86_64')
+url="http://www.mstream.io/"
+license=('GPL3')
+depends=('alsa-lib'
+ 'gtk2'
+ 'libxtst'
+ 'gconf'
+ 'libxss'
+ 'gcc-libs-multilib'
+ 'nss')
+conflicts=('mstreamexpress')
+replaces=('mstreamexpress')
+source=("https://github.com/IrosTheBeggar/mStream/releases/download/v3.0.7/mstreamExpress-linux-v${pkgver}.tar.gz")
+md5sums=('eb14e68bc67fe44ca7cbf209729c0c42')
+PKGEXT='.pkg.tar'
+
+package() {
+ install -d ${pkgdir}/usr/share/licenses/${pkgname}
+ mv ${srcdir}/mstreamExpress-v${pkgver}/{LICENSE,LICENSES.chromium.html} ${pkgdir}/usr/share/licenses/${pkgname}
+
+ install -d ${pkgdir}/usr/share/${pkgname}
+ cp -r ${srcdir}/mstreamExpress-v${pkgver}/* ${pkgdir}/usr/share/${pkgname}
+ mv ${pkgdir}/usr/share/${pkgname}/mstreamExpress-v${pkgver} ${pkgdir}/usr/share/${pkgname}/mstreamexpress
+
+ install -d ${pkgdir}/usr/bin
+ ln -s /usr/share/${pkgname}/mstreamexpress ${pkgdir}/usr/bin/mstreamexpress
+}