summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDanny Grove2023-07-04 23:49:55 -0700
committerDanny Grove2023-07-04 23:49:55 -0700
commit796878f0b1fa011aeabad15edf9baad8b9f19472 (patch)
treed3070ca568f09576508c4f353a354b9276434680 /PKGBUILD
parenta62b04ee23bd0a15a58e03a926b5b6ea5e929fa0 (diff)
downloadaur-796878f0b1fa011aeabad15edf9baad8b9f19472.tar.gz
Bump to v0.17.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7ac019b21987..eae7d9a0f167 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Danny Grove <dgrove@hashbang.sh>
pkgname=mtls
-pkgver=0.16.0
-pkgrel=2
+pkgver=0.17.0
+pkgrel=1
pkgdesc="A short-lived certificate tool based on the Zero Trust network model"
url="https://github.com/drgrove/mtls-cli"
license=("Apache")
@@ -13,15 +13,15 @@ depends=("nss"
"python-pyopenssl"
"python-requests"
"python-urllib3")
-makedepends=("python-setuptools" "python-setuptools-scm")
-source=("https://pypi.io/packages/source/m/mtls/${pkgname}-${pkgver}.tar.gz"{,.asc})
-sha256sums=('3dfd2e437150844900c7945755b1d4cf39867717215a3fef76a4df388057a945'
+makedepends=("python-setuptools" "python-setuptools-scm" "python-build" "python-installer")
+source=("https://github.com/drGrove/mtls-cli/releases/download/v${pkgver}/mtls-${pkgver}.tar.gz"{,.asc})
+sha256sums=('f432008694b778caec659a66f8bcb399b62da6e525ade8861529b586a0fb9886'
'SKIP')
validpgpkeys=('C92FE5A3FBD58DD3EC5AA26BB10116B8193F2DBD') # Danny Grove <dgrove@hashbang.sh>
build() {
cd "$srcdir/$pkgname-$pkgver"
- python setup.py build
+ python -m build
_MTLS_COMPLETE=zsh_source python -c 'import sys;from mtls.cli import cli;sys.argv[0]="mtls";cli()' > completion.zsh || true
_MTLS_COMPLETE=bash_source python -c 'import sys;from mtls.cli import cli;sys.argv[0]="mtls";cli()' > completion.bash || true
_MTLS_COMPLETE=fish_source python -c 'import sys;from mtls.cli import cli;sys.argv[0]="mtls";cli()' > completion.fish || true
@@ -29,7 +29,7 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir/" --no-compile-bytecode dist/$pkgname-$pkgver-py3-none-any.whl
install -Dm644 completion.bash "$pkgdir/usr/share/bash-completion/completions/mtls"
install -Dm644 completion.fish "$pkgdir/usr/share/fish/vendor_completions.d/mtls.fish"
install -Dm644 completion.zsh "$pkgdir/usr/share/zsh/site-functions/_mtls"