summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorilona2020-05-24 16:36:14 -0500
committerilona2020-05-24 16:36:14 -0500
commite6fb664fe28a7ee2c129a4087cb0d235cc5d7f7a (patch)
tree5d6bdb1af4fc12a9e6a8a72eadc4ef5c94facfca /PKGBUILD
downloadaur-e6fb664fe28a7ee2c129a4087cb0d235cc5d7f7a.tar.gz
add PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e010253ee86b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# maintainer: <2k20@riseup.net> ילאָנאַ
+
+pkgname=mtmigrate
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="mtmigrate (music torrent migrate) is a tool to help you with migrating your old data to a new torrent swarm."
+arch=('armv6h' 'armv7h' 'aarch64' 'i686' 'x86_64')
+url="https://github.com/ThomasColliers/mtmigrate"
+license=('MIT')
+groups=('gazelle-tools')
+makedepends=('rust')
+source=("git+https://github.com/ThomasColliers/mtmigrate")
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}"/"${pkgname}"
+ cargo build --release
+}
+
+package() {
+ cd "${srcdir}"/"${pkgname}"
+ install -Dm 755 target/release/"${pkgname}" "${pkgdir}"/usr/bin/"${pkgname}"
+}