summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLisa White2019-11-18 13:08:36 +0000
committerLisa White2019-11-18 13:11:07 +0000
commitdf79050281e52720fe151116c3acd389ffd00376 (patch)
tree55f62c75d19b1cc8db0d038d3eb068ede7a18c48 /PKGBUILD
parenta2c48b1695b8365dca9488a6a2c7d025b03bde6b (diff)
downloadaur-df79050281e52720fe151116c3acd389ffd00376.tar.gz
Restart mtproxy after config update and on failure, patch out 'pid is 32 bit' assertion
Co-authored-by: Yaroslav Dronskiy <jaroslav@dronsky.ru>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 806541706142..3f393b41572c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,11 +12,13 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-# Maintainer: Aleksey Filippov <sarum9in@gmail.com>
+# Maintainer: Lisa White <lisa.rsfp+dev@gmail.com>
+# Contributor: Yaroslav Dronskiy <jaroslav@dronsky.ru>
+# Contributor: Aleksey Filippov <sarum9in@gmail.com>
pkgname=mtproxy-git
-pkgver=17.580909c
-pkgrel=2
+pkgver=47.dc0c7f3
+pkgrel=1
pkgdesc="Proxy server for Telegram messaging app"
arch=('i686' 'x86_64')
url='https://github.com/TelegramMessenger/MTProxy'
@@ -28,13 +30,15 @@ source=(
mtproxy-config.service
mtproxy-config.timer
mtproxy.service
+ pid_assertion.patch
)
noextract=()
md5sums=('SKIP'
'1a9cdcef498d2e9ffb5def0112c3e2b0'
- '6ceb39b6a8462bc21c0940fd6ca5650e'
+ 'a67f6a3b3874d9dac15c7cf620d696c2'
'aa2367c3f759632473824fabcc3544ff'
- 'c08b4b281c1e8c8587b04743f70cff0d')
+ '1ee66acee6c42aca9160b9ccfe534bc3'
+ '50233354ac78d52280a93092b809f7aa')
backup=('etc/mtproxy.conf')
pkgver() {
@@ -42,6 +46,11 @@ pkgver() {
echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
+prepare() {
+ cd "$srcdir/$pkgname"
+ patch --forward --strip=1 --input="$srcdir/pid_assertion.patch"
+}
+
build() {
cd "$srcdir/$pkgname"
make $MFLAGS