summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJaroslav Lichtblau2015-06-28 19:59:13 +0200
committerJaroslav Lichtblau2015-06-28 19:59:13 +0200
commit5811dff00c8ef1f7d81e5fa682114685d81d81db (patch)
tree0fc680035ff7888bd5d9945dad1a02186405d24b /PKGBUILD
downloadaur-5811dff00c8ef1f7d81e5fa682114685d81d81db.tar.gz
mu transfer to AUR4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6899710eb9b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: megadriver <megadriver at gmx dot com>
+# Contributor: Tom Willemsen <tom at ryuslash dot org>
+# Contributor: Uwe <moc liamg skcuneelu <-- look what I did there>
+# Contributor: Nicolas Pouillard <nicolas dot pouillard at gmail dot com>
+# Contributor: Vain
+
+pkgname=mu
+pkgver=0.9.11
+pkgrel=1
+pkgdesc="A collection of utilities for indexing and searching Maildirs"
+arch=('i686' 'x86_64')
+url="http://www.djcbsoftware.nl/code/mu"
+install=$pkgname.install
+license=('GPL3')
+depends=('xapian-core' 'gmime' 'sqlite3')
+optdepends=('cronie: Updating index regularly')
+conflicts=('mailutils')
+source=("https://github.com/djcb/mu/archive/v$pkgver.tar.gz")
+md5sums=('6b774454b181c9814992e7c9a24b9441')
+
+prepare() {
+ cd $srcdir/mu-$pkgver
+ cd toys/mug
+ sed -i 's|MUGDIR|"/usr/share/pixmaps"|g' mug.c
+}
+
+build() {
+ cd $srcdir/mu-$pkgver
+ # msg2pdf and mug will be built only if webkitgtk is installed
+ autoreconf --force --install
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $srcdir/mu-$pkgver
+ make DESTDIR=$pkgdir install
+ # if msg2pdf and mug were built, install them
+ # if not, remove the unneeded mug manpage
+ if [ -f toys/msg2pdf/msg2pdf ]; then
+ install -m755 toys/msg2pdf/msg2pdf $pkgdir/usr/bin/msg2pdf
+ fi
+ if [ -f toys/mug/mug ]; then
+ install -m755 toys/mug/mug $pkgdir/usr/bin/mug
+ install -Dm644 toys/mug/mug.svg $pkgdir/usr/share/pixmaps/mug.svg
+ else
+ rm $pkgdir/usr/share/man/man1/mug.1
+ fi
+}