summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarcel Röthke2022-06-25 22:42:40 +0200
committerMarcel Röthke2022-06-25 22:42:40 +0200
commit9a0b06ebfa7e2fdf29fa97b967c811c54494d009 (patch)
tree04020ee6ff2ed4a807c7ee09580b4b2d9bd0ba69 /PKGBUILD
parente1706144377b59f6d15cb08dec6cf98d83f1a941 (diff)
downloadaur-9a0b06ebfa7e2fdf29fa97b967c811c54494d009.tar.gz
mu: upstream release 1.8.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 17 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4b2e012747c3..1b0cb4e09da4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,32 +3,40 @@
# Contributor: csllbr; Popsch <popsch@gmx.net>
pkgname=mu
-pkgver=1.6.11
+pkgver=1.8.0
pkgrel=1
pkgdesc="Maildir indexer/searcher and Emacs client (mu4e)"
arch=("x86_64" "armv7h")
url="http://www.djcbsoftware.nl/code/mu"
license=("GPL")
depends=("gmime3" "xapian-core")
-makedepends=("emacs" "guile")
-optdepends=("guile: guile support"
+makedepends=("emacs" "guile" "meson")
+optdepends=("guile3: guile support"
"emacs: mu4e support")
-source=("mu-$pkgver.tar.gz::https://github.com/djcb/mu/archive/$pkgver.tar.gz")
-md5sums=('119242f28e002db33d7c8b78940f24fd')
+source=("https://github.com/djcb/mu/releases/download/v${pkgver}/mu-${pkgver}.tar.xz")
+md5sums=('c451114eded74a75e6b7a52498b36d7e')
prepare() {
cd "$pkgname-$pkgver"
- autoreconf -i
+ meson \
+ build \
+ --prefix=/usr \
+ --buildtype=plain \
+ -Dc_args="${CFLAGS}" \
+ -Dcpp_args="${CFLAGS}" \
+ -Dc_link_args="${LDFLAGS}" \
+ -Dcpp_link_args="${LDFLAGS}" \
+ -Dguile=enabled \
+ -Dreadline=enabled
}
build() {
cd "$pkgname-$pkgver"
- ./configure --prefix=/usr --disable-webkit --disable-gtk --enable-mu4e --enable-guile
- make
+ ninja -C build
}
package() {
cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir" install
+ DESTDIR="${pkgdir}" meson install -C build
}