summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-03-27 10:18:16 +0100
committerAlexander F. Rødseth2019-03-27 10:18:16 +0100
commitf07fabc54deda47b4bbdc2e921ffaeee8b34997c (patch)
tree0eef8375adee72439fca473b8d9764a072f8e35f /PKGBUILD
parentb56586dde2295dfa413ff8e935f323a8c1a78314 (diff)
downloadaur-f07fabc54deda47b4bbdc2e921ffaeee8b34997c.tar.gz
Move from [community] to AUR in connection with the spring cleaning
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD64
1 files changed, 19 insertions, 45 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 71879dbe8c6a..f6fb16009fb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,28 @@
-# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
-# Contributor: megadriver <megadriver at gmx dot com>
-# Contributor: Tom Willemsen <tom at ryuslash dot org>
-# Contributor: Uwe <moc liamg skcuneelu <-- look what I did there>
-# Contributor: Nicolas Pouillard <nicolas dot pouillard at gmail dot com>
-# Contributor: Vain
+# Maintainer:
+# Contributor: Pierre Neidhardt <ambrevar@gmail.com>
+# Contributor: csllbr; Popsch <popsch@gmx.net>
pkgname=mu
-pkgver=0.9.18
-pkgrel=1
-pkgdesc="A collection of utilities for indexing and searching Maildirs"
-arch=('i686' 'x86_64')
+pkgver=1.0
+pkgrel=3
+pkgdesc="Maildir indexer/searcher and Emacs client (mu4e)"
+arch=("x86_64")
url="http://www.djcbsoftware.nl/code/mu"
-license=('GPL3')
-depends=('xapian-core' 'gmime' 'sqlite')
-makedepends=('webkitgtk')
-optdepends=('cron: Updating index regularly'
- 'webkitgtk: for msg2pdf and GUI')
-conflicts=('mailutils')
-install=$pkgname.install
-source=(https://github.com/djcb/mu/releases/download/$pkgver/$pkgname-$pkgver.tar.gz)
-sha256sums=('6559ec888d53f8e03b87b67148a73f52fe086477cb10e43f3fc13ed7f717e809')
-
-prepare() {
- cd "${srcdir}"/$pkgname-$pkgver/toys/mug
-
- sed -i 's|MUGDIR|"/usr/share/pixmaps"|g' mug.c
-}
+license=("GPL")
+depends=("gmime" "xapian-core" "guile2.0")
+makedepends=("emacs")
+optdepends=("guile: guile support"
+ "emacs: mu4e support")
+source=("https://github.com/djcb/mu/archive/v$pkgver.tar.gz")
+md5sums=('b415f84d4538cf05ec3360a449c1de4d')
build() {
- cd "${srcdir}"/$pkgname-$pkgver
-
- # msg2pdf and mug will be built only if webkitgtk is installed
- autoreconf --force --install
- ./configure --prefix=/usr
- make
+ cd "$pkgname-$pkgver"
+ autoreconf -i
+ ./configure --prefix=/usr --disable-webkit --disable-gtk --enable-mu4e --enable-guile
}
package() {
- cd "${srcdir}"/$pkgname-$pkgver
-
- make DESTDIR="${pkgdir}" install
- # if msg2pdf and mug were built, install them
- # if not, remove the unneeded mug manpage
- if [ -f toys/msg2pdf/msg2pdf ]; then
- install -m755 toys/msg2pdf/msg2pdf "${pkgdir}"/usr/bin/msg2pdf
- fi
- if [ -f toys/mug/mug ]; then
- install -m755 toys/mug/mug "${pkgdir}"/usr/bin/mug
- install -Dm644 toys/mug/mug.svg "${pkgdir}"/usr/share/pixmaps/mug.svg
- else
- rm "${pkgdir}"/usr/share/man/man1/mug.1
- fi
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
}