summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorchristian2015-06-09 21:23:40 +0200
committerchristian2015-06-09 21:23:40 +0200
commita98a1990f231ce57d1ac4003c70d560b3fc71563 (patch)
tree62dd5474863703013d40745454dea23a86987b72 /PKGBUILD
downloadaur-a98a1990f231ce57d1ac4003c70d560b3fc71563.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84d1cf961650
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: csllbr; Popsch <popsch@gmx.net>
+# Thanks to the maintainers and contributors of the mu binary package
+
+pkgname=mu-git
+pkgver=v0.9.11.97.g646b065
+pkgrel=2
+pkgdesc="mu and mu4e from git"
+arch=('i686' 'x86_64')
+url="http://www.djcbsoftware.nl/code/mu"
+depends=(xapian-core gmime sqlite3)
+makedepends=(git libtool)
+optdepends=('guile: guile support',
+ 'emacs: mu4e support')
+license=('GPL')
+provides=('mu')
+conflicts=('mu')
+
+source=('git+https://github.com/djcb/mu.git')
+md5sums=('SKIP')
+pkgver() {
+ cd mu
+ printf "%s" "$(git describe --tags|sed 's+-+.+g')"
+}
+
+build() {
+ cd mu
+ autoreconf -i
+ sed -i 's|MUGDIR|"/usr/share/pixmaps"|' toys/mug/mug.c
+ ./configure --prefix=/usr --disable-webkit --disable-gtk
+}
+
+package() {
+ cd mu
+ make DESTDIR=$pkgdir install
+ install -Dm644 COPYING $pkgdir/usr/share/licenses/mu/COPYING
+}