summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2019-02-08 21:42:43 +0100
committerhaawda2019-02-08 21:42:43 +0100
commitc05d58d749a6a16cec7e305c1a2cd49112532a98 (patch)
treee54b589e977ad838cce4ae855f3a7fb070889281 /PKGBUILD
parent7404686b4712e0c63fddae27627b33f9be4a0d34 (diff)
downloadaur-c05d58d749a6a16cec7e305c1a2cd49112532a98.tar.gz
adopted and incorporated most of the suggestions from AUR comments
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05b5fe046250..798b810e8b7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,23 @@
# Thanks to the maintainers and contributors of the mu binary package
pkgname=mu-git
-pkgver=v0.9.16.95.g7585506
+pkgver=1.0.154.g156c4211
pkgrel=1
-install=mu-git.install
pkgdesc="mu and mu4e from git"
arch=('i686' 'x86_64')
url="http://www.djcbsoftware.nl/code/mu"
-depends=(xapian-core gmime sqlite3)
-makedepends=(git libtool)
-optdepends=('guile: guile support',
- 'emacs: mu4e support')
+depends=('xapian-core' 'guile' 'gmime3' 'json-glib' 'sqlite3')
+makedepends=('git')
+optdepends=('emacs: mu4e support')
license=('GPL')
provides=('mu')
conflicts=('mu')
-
source=('git+https://github.com/djcb/mu.git')
md5sums=('SKIP')
+
pkgver() {
cd mu
- printf "%s" "$(git describe --tags|sed 's+-+.+g')"
+ printf "%s" "$(git describe --tags|tr - .|cut -c2-)"
}
build() {
@@ -32,5 +30,5 @@ build() {
package() {
cd mu
- make DESTDIR=$pkgdir install
+ make DESTDIR="$pkgdir" install
}