summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpeeweep2019-11-02 00:51:15 +0800
committerpeeweep2019-11-02 00:51:15 +0800
commitd99956c5cf82791bbbe961ad9bd497a138fb6936 (patch)
treed81c04e2968aea212580d0b783f97361e577212b /PKGBUILD
parent06ff44cdb3194c949761206e80ca46985721c137 (diff)
downloadaur-d99956c5cf82791bbbe961ad9bd497a138fb6936.tar.gz
bump version 2.0.0-3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05383c7c69f1..e9683b6735cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=muduo
pkgver=2.0.0
-pkgrel=2
+pkgrel=3
pkgdesc='A C++ non-blocking multi-threaded network library'
url='https://github.com/chenshuo/muduo'
license=(BSD)
@@ -11,18 +11,18 @@ arch=(i686 x86_64)
depends=(protobuf)
makedepends=(cmake boost)
options=(staticlibs)
-source=(muduo-$pkgver.zip::https://github.com/chenshuo/muduo/archive/v$pkgver.zip)
+source=(${pkgname}-$pkgver.tar.gz::${url}/archive/v$pkgver.tar.gz)
sha1sums=('ba73e559a060479550167694e6b939a97ea6fec4')
build() {
- cd muduo-$pkgver
+ cd "${srcdir}/${pkgname}-$pkgver"
sed -i '/-Werror/d' CMakeLists.txt
sed -i 's/option(MUDUO_BUILD_EXAMPLES "Build Muduo examples" ON/option(MUDUO_BUILD_EXAMPLES "Build Muduo examples" OFF/' CMakeLists.txt
INSTALL_DIR=/usr ./build.sh
}
package() {
- cd build/release-cpp11
- make install DESTDIR="$pkgdir"
+ cd "${srcdir}/build/release-cpp11"
+ make install DESTDIR="${pkgdir}"
install -Dm644 "${srcdir}/${pkgname}-$pkgver/License" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}