summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authororhun2020-10-26 13:19:39 +0300
committerorhun2020-10-26 13:19:39 +0300
commit59e57a13ae57e9378dd47d20d9560bba4c1a7e8a (patch)
treea3725a9176a6831537ae40d812ad9931547a8e0b /PKGBUILD
downloadaur-59e57a13ae57e9378dd47d20d9560bba4c1a7e8a.tar.gz
Initial upload: muffet-bin 2.2.2-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d11456640f30
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=muffet-bin
+pkgdesc="Fast website link checker"
+pkgver=2.2.2
+pkgrel=1
+arch=('x86_64')
+url="https://github.com/raviqqe/muffet"
+license=('MIT')
+conflicts=("${pkgname%-bin}" "${pkgname%-bin}-git")
+provides=("${pkgname%-bin}")
+source_x86_64=("$url/releases/download/v$pkgver/${pkgname%-bin}_${pkgver}_Linux_x86_64.tar.gz")
+sha256sums_x86_64=('183426a47f457a17c9fb86b7433bc25ec65c4e66c0ff1c7c2311792ea4bbd3ad')
+
+package() {
+ install -Dm 755 "${pkgname%-bin}" -t "$pkgdir/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/${pkgname%-bin}"
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-bin}"
+}