summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonathan Boyle2021-02-13 23:58:18 +0000
committerJonathan Boyle2021-02-13 23:58:18 +0000
commit01b5704c1fde970d400c35d1672b6f5d8435a151 (patch)
tree173008af3f5dffe6910cd71bd8340ac9ff6a53a9 /PKGBUILD
downloadaur-01b5704c1fde970d400c35d1672b6f5d8435a151.tar.gz
Initial Commit of Version 0.23.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8035403c0fd3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jonathan Boyle <programmerfalcon@gmail.com>
+pkgname=mulle-sourcetree
+pkgver=0.23.1
+pkgrel=1
+epoch=1
+pkgdesc="Project composition and maintenance with build support"
+arch=('any')
+url="https://github.com/mulle-sde/mulle-sourcetree"
+license=('BSD3')
+groups=('mulle-sde-all')
+depends=('bash' 'mulle-bashfunctions>=3.3.0')
+changelog="RELEASENOTES.md"
+source=("https://github.com/mulle-sde/mulle-sourcetree/archive/0.23.1.tar.gz")
+noextract=()
+md5sums=('b3d7027643c95b5abb7bcabd237637e6')
+validpgpkeys=()
+
+package() {
+ # Install License
+ cd "${pkgname}-${pkgver}"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ # Run Install
+ cd bin
+ chmod +x installer
+ ./installer "${pkgdir}/usr"
+
+ # Move libexec to lib/$pkgname
+ cd "${pkgdir}/usr"
+ mkdir -p "lib/${pkgname}"
+ mv libexec/* "lib/${pkgname}"
+ rm -r libexec
+}