summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2022-06-13 08:31:33 -0600
committerMark Wagie2022-06-13 08:31:33 -0600
commitd36f685b682f65133e645f4f116b9559980abbe5 (patch)
treebca38326fbb73995747304aad4cc11e34762950f /PKGBUILD
parent9dec19c8b25ae9207cbae5eb81c90e784bdb8798 (diff)
downloadaur-d36f685b682f65133e645f4f116b9559980abbe5.tar.gz
2022.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 21 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f789779aa20d..cbf4b46a292f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# Contributor: Emīls Piņķis <emil at mullvad dot net>
# Contributor: Andrej Mihajlov <and at mullvad dot net>
pkgname=mullvad-vpn
-pkgver=2022.1
+pkgver=2022.2
pkgrel=1
pkgdesc="The Mullvad VPN client app for desktop"
arch=('x86_64')
@@ -17,11 +17,10 @@ depends=('iputils' 'libnotify' 'libappindicator-gtk3' 'nss')
makedepends=('cargo' 'git' 'go' 'npm' 'libxcrypt-compat')
options=('!lto')
install="$pkgname.install"
-_tag=9797300613176b73497b7c3f090199e1ffe3229b
-_commit=973ee47bec89df537b8ecae20235071055693ec5
+_tag=a66504d6b8cc708a1da4b4e6b40fbe51e9dde4d2 # tags/2022.2^0
+_commit=b63c5c8c7977963aeb585b6ddd4537dffe2aeeec
source=("git+https://github.com/mullvad/mullvadvpn-app.git#commit=${_tag}?signed"
-# "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}?signed"
- "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}" # unverified commit by mvd-ows
+ "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}?signed"
"$pkgname.sh")
sha256sums=('SKIP'
'SKIP'
@@ -67,14 +66,13 @@ prepare() {
build() {
cd "$srcdir/mullvadvpn-app"
local RUSTC_VERSION=$(rustc --version)
- local PRODUCT_VERSION=$(node -p "require('./gui/package.json').version" | \
- sed -Ee 's/\.0//g')
+ local PRODUCT_VERSION=$(cd gui/; node -p "require('./package.json').version" | sed -Ee 's/\.0//g')
source env.sh ""
- echo "Building Mullvad VPN $PRODUCT_VERSION..."
+ echo "Building Mullvad VPN ${PRODUCT_VERSION}..."
echo "Updating version in metadata files..."
- ./version-metadata.sh inject $PRODUCT_VERSION --desktop
+ ./version-metadata.sh inject ${PRODUCT_VERSION} --desktop
echo "Building wireguard-go..."
pushd wireguard/libwg
@@ -92,7 +90,7 @@ build() {
export MULLVAD_ADD_MANIFEST="1"
- echo "Building Rust code in release mode using $RUSTC_VERSION..."
+ echo "Building Rust code in release mode using ${RUSTC_VERSION}..."
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
@@ -100,8 +98,8 @@ build() {
mkdir -p dist-assets/shell-completions
for sh in bash zsh fish; do
- echo "Generating shell completion script for $sh..."
- cargo run --bin mullvad --frozen --release -- shell-completions "$sh" \
+ echo "Generating shell completion script for ${sh}..."
+ cargo run --bin mullvad --frozen --release -- shell-completions ${sh} \
dist-assets/shell-completions/
done
@@ -115,15 +113,12 @@ build() {
mullvad-exclude
)
for binary in ${binaries[*]}; do
- cp "target/release/$binary" "dist-assets/$binary"
+ cp target/release/${binary} dist-assets/${binary}
done
echo "Updating relay list..."
cargo run --bin relay_list --frozen --release > dist-assets/relays.json
- echo "Updating API address cache..."
- cargo run --bin address_cache --frozen --release > dist-assets/api-ip-address.txt
-
# Build Electron GUI app
pushd gui
echo "Packing final release artifact..."
@@ -146,15 +141,15 @@ package() {
# Install main files
install -d "$pkgdir/opt/Mullvad VPN"
- cp -r dist/linux-unpacked/* "$pkgdir/opt/Mullvad VPN"
+ cp -r dist/linux-unpacked/* "$pkgdir/opt/Mullvad VPN/"
# Symlink daemon service to correct directory
install -d "$pkgdir/usr/lib/systemd/system"
ln -s "/opt/Mullvad VPN/resources/mullvad-daemon.service" \
- "$pkgdir/usr/lib/systemd/system"
+ "$pkgdir/usr/lib/systemd/system/"
# Install binaries
- install -Dm755 dist-assets/{mullvad,mullvad-exclude} -t "$pkgdir/usr/bin"
+ install -Dm755 dist-assets/{mullvad,mullvad-exclude} -t "$pkgdir/usr/bin/"
# Link to the problem report binary
ln -s "/opt/Mullvad VPN/resources/mullvad-problem-report" \
@@ -164,23 +159,22 @@ package() {
install -m755 "$srcdir/$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
# Install completions
- install -Dm755 dist-assets/shell-completions/mullvad.bash \
+ install -Dm644 dist-assets/shell-completions/mullvad.bash \
"$pkgdir/usr/share/bash-completion/completions/mullvad"
- install -Dm755 dist-assets/shell-completions/_mullvad -t \
- "$pkgdir/usr/share/zsh/site-functions"
- install -Dm755 dist-assets/shell-completions/mullvad.fish -t \
- "$pkgdir/usr/share/fish/vendor_completions.d"
+ install -Dm644 dist-assets/shell-completions/_mullvad -t \
+ "$pkgdir/usr/share/zsh/site-functions/"
+ install -Dm644 dist-assets/shell-completions/mullvad.fish -t \
+ "$pkgdir/usr/share/fish/vendor_completions.d/"
# Install desktop file & icons from deb
cd dist
ar x *.deb
bsdtar -xf data.tar.xz
install -Dm644 "usr/share/applications/$pkgname.desktop" -t \
- "$pkgdir/usr/share/applications"
+ "$pkgdir/usr/share/applications/"
for icon_size in 16 32 48 64 128 256 512 1024; do
icons_dir=usr/share/icons/hicolor/${icon_size}x${icon_size}/apps
- install -d $pkgdir/$icons_dir
- install -m644 $icons_dir/$pkgname.png -t $pkgdir/$icons_dir
+ install -Dm644 ${icons_dir}/$pkgname.png -t "$pkgdir/${icons_dir}/"
done
}