summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2022-10-05 08:40:24 -0600
committerMark Wagie2022-10-05 08:40:24 -0600
commit61fb354af83837069ff76afcc9dbd6cd232020da (patch)
tree180508e48a58a04da7c059a2d634feb7e81e5184 /PKGBUILD
parent64392eb5b650441daad58475f2bf2002d8e9b283 (diff)
downloadaur-61fb354af83837069ff76afcc9dbd6cd232020da.tar.gz
2022.5-beta2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 28 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e32dc61ce48..999d928f1d90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,16 @@
# Contributor: Emīls Piņķis <emil at mullvad dot net>
# Contributor: Andrej Mihajlov <and at mullvad dot net>
pkgname=mullvad-vpn-beta
-_pkgver=2022.4
-_channel=stable
-_rel=1
+_pkgver=2022.5
+_channel=beta
+_rel=2
# beta
-#pkgver=${_pkgver}.${_channel}${_rel}
+pkgver=${_pkgver}.${_channel}${_rel}
# stable
-pkgver=${_pkgver}.${_channel}
+#pkgver=${_pkgver}.${_channel}
pkgrel=1
pkgdesc="The Mullvad VPN client app for desktop (beta channel)"
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://www.mullvad.net"
license=('GPL3')
depends=('iputils' 'libnotify' 'libappindicator-gtk3' 'nss')
@@ -23,13 +23,15 @@ provides=("${pkgname%-beta}")
conflicts=("${pkgname%-beta}")
options=('!lto')
install="${pkgname%-beta}.install"
-_tag=06c847a7a7d72a148bd5dba0a44860eb1b3aa182 # tags/2022.4^0
-_commit=b63c5c8c7977963aeb585b6ddd4537dffe2aeeec
+_tag=592e3092fe9b3845788a3982dca5745f6cbd47bc # tags/2022.5-beta2^0
+_commit=f6dca66645c82501a330416ad39c7e63bcdae57d
source=("git+https://github.com/mullvad/mullvadvpn-app.git#commit=${_tag}?signed"
"git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}?signed"
+ 'no-rpm.diff'
"${pkgname%-beta}.sh")
sha256sums=('SKIP'
'SKIP'
+ 'ea35edffea2cbbb05586abce19581fdd9f133801ed47e6af30fa64a29c5cf116'
'a59c29f07b4eab9af56f0e8be42bae0d83726f5185e88de0c5a48f4098c3c0a4')
validpgpkeys=('EA0A77BF9E115615FC3BD8BC7653B940E494FE87' # Linus Färnstrand (code signing key) <linus@mullvad.net>
'8339C7D2942EB854E3F27CE5AEE9DECFD582E984' # David Lönnhager (code signing) <david.l@mullvad.net>
@@ -42,7 +44,7 @@ prepare() {
git submodule update
# Disable building of rpm
- sed -i "s/'deb', 'rpm'/'deb'/g" gui/tasks/distribution.js
+ patch --strip=1 gui/tasks/distribution.js < ../no-rpm.diff
export RUSTUP_TOOLCHAIN=stable
echo "Removing old Rust build artifacts"
@@ -68,13 +70,9 @@ build() {
cd "$srcdir/mullvadvpn-app"
local RUSTC_VERSION=$(rustc --version)
local PRODUCT_VERSION=$(cd gui/; node -p "require('./package.json').version" | sed -Ee 's/\.0//g')
- source env.sh ""
echo "Building Mullvad VPN ${PRODUCT_VERSION}..."
- echo "Updating version in metadata files..."
- ./version-metadata.sh inject ${PRODUCT_VERSION} --desktop
-
echo "Building wireguard-go..."
pushd wireguard/libwg
export GOPATH="$srcdir/gopath"
@@ -89,14 +87,12 @@ build() {
# Clean module cache for makepkg -C
go clean -modcache
- export MULLVAD_ADD_MANIFEST="1"
-
echo "Building Rust code in release mode using ${RUSTC_VERSION}..."
-
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
cargo build --frozen --release
+ echo "Preparing for packaging Mullvad VPN ${PRODUCT_VERSION}..."
mkdir -p dist-assets/shell-completions
for sh in bash zsh fish; do
echo "Generating shell completion script for ${sh}..."
@@ -104,7 +100,9 @@ build() {
dist-assets/shell-completions/
done
- echo "Copying binaries"
+ echo "Updating relays.json..."
+ cargo run --bin relay_list --frozen --release > dist-assets/relays.json
+
binaries=(
mullvad-daemon
mullvad
@@ -117,12 +115,9 @@ build() {
cp target/release/${binary} dist-assets/${binary}
done
- echo "Updating relay list..."
- cargo run --bin relay_list --frozen --release > dist-assets/relays.json
-
- # Build Electron GUI app
+ # Build Electron GUI
pushd gui
- echo "Packing final release artifact..."
+ echo "Packing Mullvad VPN ${PRODUCT_VERSION} artifact(s)..."
export npm_config_cache="$srcdir/npm_cache"
npm run pack:linux
popd
@@ -142,15 +137,21 @@ package() {
# Install main files
install -d "$pkgdir/opt/Mullvad VPN"
- cp -r dist/linux-unpacked/* "$pkgdir/opt/Mullvad VPN/"
- # Symlink daemon service to correct directory
- install -d "$pkgdir/usr/lib/systemd/system"
- ln -s "/opt/Mullvad VPN/resources/mullvad-daemon.service" \
+ if [ $CARCH == "aarch64" ]; then
+ cp -r dist/linux-arm64-unpacked/* "$pkgdir/opt/Mullvad VPN/"
+ else
+ cp -r dist/linux-unpacked/* "$pkgdir/opt/Mullvad VPN/"
+ fi
+
+ chmod 4755 "$pkgdir/opt/Mullvad VPN/chrome-sandbox"
+
+ # Install services
+ install -Dm644 dist-assets/linux/{mullvad-daemon,mullvad-early-boot-blocking}.service -t \
"$pkgdir/usr/lib/systemd/system/"
# Install binaries
- install -Dm755 dist-assets/{mullvad,mullvad-exclude} -t "$pkgdir/usr/bin/"
+ install -Dm755 dist-assets/{mullvad,mullvad-daemon,mullvad-exclude} -t "$pkgdir/usr/bin/"
# Link to the problem report binary
ln -s "/opt/Mullvad VPN/resources/mullvad-problem-report" \