summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2023-06-28 08:52:30 -0600
committerMark Wagie2023-06-28 08:52:30 -0600
commitb98597500c9f273ae3d1fbf14fdfeb27d2e731ed (patch)
treebeb09ba8a2cb5b5df1ad5c2924540540f86486a0 /PKGBUILD
parent95a0010d5afaed72cd75383f6daa87d6faf8fabc (diff)
downloadaur-b98597500c9f273ae3d1fbf14fdfeb27d2e731ed.tar.gz
2023.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d16ad2f9f653..4301a8aaaabf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,22 +6,22 @@
# Contributor: Andrej Mihajlov <and at mullvad dot net>
pkgname=mullvad-vpn-beta
_pkgver=2023.4
-_channel=beta
+_channel=stable
_rel=1
-pkgver=${_pkgver}.${_channel}${_rel} # beta
-#pkgver=${_pkgver}.${_channel} # stable
+#pkgver=${_pkgver}.${_channel}${_rel} # beta
+pkgver=${_pkgver}.${_channel} # stable
pkgrel=1
pkgdesc="The Mullvad VPN client app for desktop (beta channel)"
arch=('x86_64')
url="https://www.mullvad.net"
license=('GPL3')
-depends=('iputils' 'libnotify' 'libappindicator-gtk3' 'nss')
+depends=('gtk3' 'iputils' 'libnotify' 'nss')
makedepends=('cargo' 'git' 'go' 'libxcrypt-compat' 'nodejs>=16' 'npm>=8.3' 'protobuf')
provides=("${pkgname%-beta}")
conflicts=("${pkgname%-beta}")
options=('!lto')
install="${pkgname%-beta}.install"
-_tag=96bc061de442377a5f0a4a7981461a8efbb38ae6 # tags/2023.4-beta1^0
+_tag=a64b10fdd4c9fefa6d25fd2a94c0ea6cbc7eebc0 # tags/2023.4^0
_commit=29a4c7205e78c651fcd1b8c3a55181c0d86a50d3
source=("git+https://github.com/mullvad/mullvadvpn-app.git#commit=${_tag}?signed"
"git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}?signed"
@@ -86,7 +86,6 @@ build() {
go clean -modcache
echo "Building Rust code in release mode using ${RUSTC_VERSION}..."
- export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
cargo build --frozen --release