summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2023-10-10 10:59:35 -0600
committerMark Wagie2023-10-10 10:59:35 -0600
commit2e2e93e6387490e3bbf671249e92fe1d286a9eb7 (patch)
treed9cbea546ffeaf6ca13b864c80bfafdcecb9c04a /PKGBUILD
parente5a8e5730712603aaea76d90836bdccc3572f439 (diff)
downloadaur-2e2e93e6387490e3bbf671249e92fe1d286a9eb7.tar.gz
2023.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2f1ced289d82..04603abdba2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
# Contributor: Matthew McGinn <mamcgi at gmail dot com>
# Contributor: alicewww <almw at protonmail dot com>
pkgname=mullvad-vpn-bin
-pkgver=2023.4
+pkgver=2023.5
pkgrel=1
pkgdesc="The Mullvad VPN client app for desktop"
arch=('x86_64' 'aarch64')
url="https://www.mullvad.net"
license=('GPL3')
depends=('gtk3' 'iputils' 'libnotify' 'nss')
-provides=("${pkgname%-*}")
-conflicts=("${pkgname%-*}")
-install="${pkgname%-*}.install"
-source=("${pkgname%-*}.sh")
+provides=('mullvad-vpn')
+conflicts=('mullvad-vpn')
+install='mullvad-vpn.install'
+source=('mullvad-vpn.sh')
source_x86_64=("https://github.com/mullvad/mullvadvpn-app/releases/download/$pkgver/MullvadVPN-${pkgver}_amd64.deb"{,.asc})
source_aarch64=("https://github.com/mullvad/mullvadvpn-app/releases/download/$pkgver/MullvadVPN-${pkgver}_arm64.deb"{,.asc})
sha256sums=('a59c29f07b4eab9af56f0e8be42bae0d83726f5185e88de0c5a48f4098c3c0a4')
-sha256sums_x86_64=('ecda227eb5f5ff7a542474d82bed9d568b3fa05b0a898c328421a2d3b4ac1213'
+sha256sums_x86_64=('16956bb88f343e6a41a3626b32f82f3a0ee8bba2dc7937a2b7d1db58a81c3dae'
'SKIP')
-sha256sums_aarch64=('7b4969f92a41526b5805c24fbea97c00b782915b67799d427772053155fa4764'
+sha256sums_aarch64=('365621f0ae576da778c52a19d36c82e5f8774ab433c8dc92f6ea00ef7444729a'
'SKIP')
validpgpkeys=('A1198702FC3E0A09A9AE5B75D5A1D4F266DE8DDF') # Mullvad (code signing) <admin@mullvad.net>
@@ -27,7 +27,7 @@ package() {
chmod 4755 "$pkgdir/opt/Mullvad VPN/chrome-sandbox"
# Link to the GUI binary
- install -m755 "$srcdir/${pkgname%-*}.sh" "$pkgdir/usr/bin/${pkgname%-*}"
+ install -m755 "$srcdir/mullvad-vpn.sh" "$pkgdir/usr/bin/mullvad-vpn"
# Move ZSH completions to correct directory
mv "$pkgdir/usr/local/share/zsh" "$pkgdir/usr/share/"