summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzetaPRIME2019-09-13 16:55:03 -0400
committerzetaPRIME2019-09-13 16:55:03 -0400
commitbe5279d1031c1cd3edb4f2339c4b074eda91a619 (patch)
tree23664df8d583ccb1a7b715b90d4a19b33e077d6a /PKGBUILD
downloadaur-be5279d1031c1cd3edb4f2339c4b074eda91a619.tar.gz
initial package creation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f327aa08c22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: zetaPRIME <qmanxt at gmail dot com>
+pkgname=multibound-git
+_realname=multibound
+pkgver=r14.104d44a
+pkgrel=1
+pkgdesc="Starbound profile launcher"
+arch=('any')
+url="https://github.com/zetaPRIME/MultiBound2/"
+license=('LGPL2')
+depends=('qt5-base' 'qt5-declarative' 'libxml++')
+makedepends=('git' 'qt5-tools')
+conflicts=('multibound')
+source=($_realname::git+https://github.com/zetaPRIME/MultiBound2.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_realname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $_realname/multibound2
+ qmake multibound2.pro
+ make
+}
+
+package() {
+ cd $_realname/multibound2
+ make INSTALL_ROOT="$pkgdir" install
+}