summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIvan2016-10-18 20:49:12 -0400
committerIvan2016-10-18 20:49:12 -0400
commitcdbbdcdded117f6ea859b2bdfecbb347938a70c5 (patch)
tree31677fa0ed6198e100af3226e48f6ef918286243 /PKGBUILD
downloadaur-cdbbdcdded117f6ea859b2bdfecbb347938a70c5.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..867239f53a08
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Ivan Lisenkov <ivan@ivlis.com>
+pkgname=mumax3
+pkgver=3.9.3
+pkgrel='1'
+pkgdesc="GPU-accelerated micromagnetic simulation program"
+arch=('x86_64')
+url="http://mumax.github.io/"
+license=('GPL')
+depends=('cuda-7.5')
+optdepends=('gnuplot: for fancy plots')
+source=("https://github.com/mumax/3/releases/download/v$pkgver/mumax${pkgver}_linux_cuda7.5.tar.gz")
+md5sums=('fbac69c0bcf40309a7f0bf61d9745228')
+
+
+package() {
+ mkdir -p ${pkgdir}/opt/mumax3/
+ cp ${srcdir}/mumax3 ${pkgdir}/opt/mumax3
+}