summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZdeněk Janák2015-07-23 12:58:05 +0200
committerZdeněk Janák2015-07-23 12:58:05 +0200
commit52261c31eeb338ca971eee08c4640b8a8afb4554 (patch)
tree535317a38ab4c1f001ea7385d95aa3dc0903ec48 /PKGBUILD
downloadaur-52261c31eeb338ca971eee08c4640b8a8afb4554.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c8841f77e64
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: Zdenek Janak <janak@physics.muni.cz>
+
+pkgname=munipack
+pkgver=0.5.6
+pkgrel=1
+pkgdesc="General astronomical photometry software package"
+arch=('i686' 'x86_64')
+url="http://munipack.physics.muni.cz/"
+license=('GPL3')
+depends=(cfitsio wxgtk webkitgtk2)
+makedepends=(gcc-fortran)
+optdepends=('fitspng: for FITS to PNG conversion'
+ 'rawtran: for RAW to FITS conversion')
+source=(ftp://integral.physics.muni.cz/pub/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('f609ee8cba91fdb63c5a3bf90277b812')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr --libexecdir=/usr/lib
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}