summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGaetan Bisson2021-08-03 22:23:06 +0200
committerGaetan Bisson2021-08-03 22:23:06 +0200
commitf9de9a0b090f7c68da09c7ac9d16a9d076dbeee7 (patch)
tree1f0e6bec0292d48c7cf3100639559053705beb98 /PKGBUILD
parentf924cd9f734d9a8d277f2ad8b80799a7a245a0c2 (diff)
downloadaur-f9de9a0b090f7c68da09c7ac9d16a9d076dbeee7.tar.gz
extract is now non-optional
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 93d48203c5cd..322ff536fa48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=mupdf-git
_pkgname=mupdf
-pkgver=20210319.33e4e2a3d
+pkgver=20210803.d8ed9ea25
pkgrel=1
pkgdesc='Lightweight PDF, XPS, and E-book viewer'
arch=('x86_64' 'armv7h' 'aarch64')
@@ -13,14 +13,16 @@ license=('AGPL3')
makedepends=('git' 'libxi' 'glu')
depends=('libxrandr' 'harfbuzz' 'jbig2dec' 'libjpeg-turbo' 'openjpeg2' 'gumbo-parser')
source=('git://git.ghostscript.com/mupdf.git'
- 'git://git.ghostscript.com/mujs.git'
- 'git://git.ghostscript.com/thirdparty-lcms2.git'
+ 'git://git.ghostscript.com/thirdparty-extract.git'
'git://git.ghostscript.com/thirdparty-freeglut.git'
+ 'git://git.ghostscript.com/thirdparty-lcms2.git'
+ 'git://git.ghostscript.com/mujs.git'
'desktop')
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'3240d4ebda002cb2c4f42cd42793c6160f1701d349d0acb797819dfd10d4fedd')
conflicts=("${_pkgname}"{,-gl,-tools})
@@ -34,9 +36,11 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
+ sed "/extract.git/c url = $(pwd)/../thirdparty-extract" -i .gitmodules
sed "/freeglut.git/c url = $(pwd)/../thirdparty-freeglut" -i .gitmodules
sed "/lcms2.git/c url = $(pwd)/../thirdparty-lcms2" -i .gitmodules
sed "/mujs.git/c url = $(pwd)/../mujs" -i .gitmodules
+ git submodule update --init thirdparty/extract
git submodule update --init thirdparty/freeglut
git submodule update --init thirdparty/lcms2
git submodule update --init thirdparty/mujs