summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2017-08-15 20:46:36 -0300
committerDaniel Bermond2017-08-15 20:46:36 -0300
commit8d7bb2865ce2bb0e44579b7d4eea5abaab0997bb (patch)
tree37a68d515de27786826356d4f86c5a07b28c1cfa /PKGBUILD
parenta1a9974fe14a4f1229bff167ce863e7830124a1e (diff)
downloadaur-8d7bb2865ce2bb0e44579b7d4eea5abaab0997bb.tar.gz
Fix build of 'ui-console' component
It needs to be compiled with -fPIC.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 65fbb2cda28d..311d4c91934b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,8 +22,8 @@
# option will force the rebuild of all git sources.
pkgname=mupen64plus-git
-pkgver=2.5.r374.g1d6d57e.20170529.153246
-pkgrel=2
+pkgver=2.5.r462.ga0672bb.20170813.001839
+pkgrel=1
pkgdesc='Nintendo64 Emulator (git version)'
arch=('i686' 'x86_64')
url='http://www.mupen64plus.org/'
@@ -201,6 +201,11 @@ build() {
_previous_version="$_prev_ver_uiconsole"
_current_version="$_curr_ver_uiconsole"
_current_date="$_curr_date_uiconsole"
+
+ # fix for 'ui-console' component (it needs to be compiled with -fPIC)
+ _target_line="$(sed -n '/^ifeq ($(OS), LINUX)/=' "mupen64plus-${_component}/projects/unix/Makefile")"
+ sed -i "$((_target_line + 1))i\ \CFLAGS += -fPIC" "mupen64plus-${_component}/projects/unix/Makefile"
+
;;
*)
printf '%s\n' "error: invalid component '${_component}' (this should not happen!)"