summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2020-04-10 20:22:55 +0000
committerDaniel Bermond2020-04-10 20:22:55 +0000
commit42a7fd2f3d63c907021fb1584e3603347cfe9523 (patch)
treea328acff2616a55284fd976b60b98322a64593e0 /PKGBUILD
parent09138bee52edc6a85b984355dd9e3005cefc5e89 (diff)
downloadaur-42a7fd2f3d63c907021fb1584e3603347cfe9523.tar.gz
Build and install fixes
- it requires Release build type - rename plugin file - install custom game ini file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 15 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e7fe9423ce1f..6c401fa609e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,49 +2,46 @@
# Contributor: Flávio Zavan <flavio dot zavan at gmail dot com>
pkgname=mupen64plus-video-gliden64-git
-pkgver=4.0.r125.g0a5216f8
+pkgver=4.0.r165.gfbd1ad1a
pkgrel=1
pkgdesc='A new generation, open-source graphics plugin for N64 emulators (git version)'
arch=('x86_64')
url='https://github.com/gonetz/GLideN64/'
license=('GPL2')
-depends=('mupen64plus')
-makedepends=('git' 'cmake' 'libgl' 'freetype2')
+depends=('mupen64plus' 'libpng' 'zlib' 'freetype2' 'libgl')
+makedepends=('git' 'cmake' 'qt5-base')
source=('git+https://github.com/gonetz/GLideN64.git')
provides=('mupenplus-video-gliden64')
conflicts=('mupenplus-video-gliden64')
sha256sums=('SKIP')
pkgver() {
- cd GLideN64
- #git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^Public_Release_//;s/^v//;s/_/./g'
+ #git -C GLideN64 describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^Public_Release_//;s/^v//;s/_/./g'
local _tag
local _version
local _revision
local _shorthash
-
- _tag="$(git tag | grep 'Public_Release' | sort | tail -n1)"
+ _tag="$(git -C GLideN64 tag | grep 'Public_Release' | sort | tail -n1)"
_version="$(printf '%s' "$_tag" | sed 's/^Public_Release_//;s/^v//;s/_/./g')"
- _revision="$(git rev-list --count "${_tag}...HEAD")"
- _shorthash="$(git rev-parse --short HEAD)"
-
+ _revision="$(git -C GLideN64 rev-list --count "${_tag}...HEAD")"
+ _shorthash="$(git -C GLideN64 rev-parse --short HEAD)"
printf '%s.r%s.g%s' "$_version" "$_revision" "$_shorthash"
}
build() {
- local _revision
- _revision="$(cd GLideN64 && git rev-parse --short HEAD)"
- printf '%s\n' "#define PLUGIN_REVISION \"${_revision}\"" > GLideN64/src/Revision.h
-
- cmake -B GLideN64/src/build -S GLideN64/src \
- -DCMAKE_BUILD_TYPE:STRING='None' \
+ cd GLideN64/src
+ ./getRevision.sh 2>/dev/null
+ cmake -B build -S . \
+ -DCMAKE_BUILD_TYPE:STRING='Release' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
-DMUPENPLUSAPI:BOOL='ON' \
+ -DUSE_SYSTEM_LIBS:BOOL='ON' \
-Wno-dev
- make -C GLideN64/src/build
+ make -C build
}
package() {
- install -D -m644 GLideN64/src/build/libmupen64plus-video-GLideN64.so -t "${pkgdir}/usr/lib/mupen64plus"
+ install -D -m644 GLideN64/src/build/plugin/Release/mupen64plus-video-GLideN64.so -t "${pkgdir}/usr/lib/mupen64plus"
+ install -D -m644 GLideN64/ini/GLideN64.custom.ini -t "${pkgdir}/usr/share/mupen64plus"
}