summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBen Mitchell2022-12-24 14:20:21 +0000
committerBen Mitchell2022-12-24 14:20:21 +0000
commit04215bad4e9ddc4cd222b4161e396a709b135aa7 (patch)
tree396e40d5db905af1a0073f0f14d61313749bc35a /PKGBUILD
parent5b8eea5cdbaaa926aea047590c83127b1cec2baa (diff)
downloadaur-04215bad4e9ddc4cd222b4161e396a709b135aa7.tar.gz
Sandboxing
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cdf45c2c1992..0af825bfbf27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ben Mitchell (bjosephmitchell@gmail.com)
pkgname=muse-hub-bin
pkgver=1.0.0.392
-pkgrel=1
+pkgrel=2
pkgdesc="Manage MuseScore Libraries."
arch=('x86_64')
url=""
@@ -14,7 +14,7 @@ install=${pkgname}.install
source=("https://pub-c7a32e5b5d834ec9aeef400105452a42.r2.dev/Muse_Hub.deb" "muse-hub.service" "muse-hub.desktop")
sha512sums=(
'8c3b145d4350e70d75548ee174331ff6bbf022cfc0dfd338828c62e99a860fed37254c55b75ac10d0e3f4475dd93e79de22a52fb6fdb5ad78d8b86de9f50f836'
- '52282b6cea0564173a20c922b5c71044d807506431f38457e0df419ca0ac6978004076e4e4985befbbe2481c6a49f3a45722970397918088fda63af1cf9c3c73'
+ '9380bc41f25263d4cab019228ff34ddff7e92c66c4a7e3b39ab48ebdc989f9e5969383889abe90f01c03f8a4c4b93224d03c8fc0753a1304d12e54de15717ad2'
'e880ed5b5c7c2f7fa78d9a3f4cb3e438b7dc1321c6e2470644d9f0ff96fe060dd34640ab0da1349d004c65179cd9b89790242a77b09adf03e5178be63d59817d'
)
@@ -23,4 +23,8 @@ package(){
tar -xJ -f data.tar.xz -C "${pkgdir}"
install -Dm644 muse-hub.service "${pkgdir}/usr/lib/systemd/system/muse-hub.service"
install -Dm644 muse-hub.desktop "${pkgdir}/usr/share/applications/muse-hub.desktop"
+
+ # Make sure directory used by Muse Hub and MuseScore has been created
+ # so we can bind it into a temporary filesystem for the service
+ mkdir -p "${pkgdir}/srv/muse-hub"
}