summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Picht2020-12-17 07:17:23 +0100
committerMichael Picht2020-12-17 07:17:23 +0100
commitee62e6dfe8443bb9cc8aa4323d89c0ddb700ae4e (patch)
treeb7005cb515830234f9860a3165800a2132caa31d /PKGBUILD
downloadaur-ee62e6dfe8443bb9cc8aa4323d89c0ddb700ae4e.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83db35e787b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Michael Picht <mipi@fsfe.org>
+
+_pkgorg=gitlab.com/mipimipi
+pkgname=muserv-git
+_pkgname=muserv
+pkgver=v0.1.27.pre
+pkgrel=1
+pkgdesc="muserv (DLNA/UPnP server for music)"
+arch=(any)
+url="https://$_pkgorg/$_pkgname/"
+license=('GPL3')
+depends=(
+ mailcap
+)
+makedepends=(
+ git
+ go-pie
+)
+source=("git+https://$_pkgorg/$_pkgname.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ mkdir -p gopath/src/$_pkgorg
+ ln -rTsf $_pkgname gopath/src/$_pkgorg/$_pkgname
+ export GOPATH="$srcdir"/gopath
+ cd gopath/src/$_pkgorg/$_pkgname
+}
+
+build() {
+ export GOPATH="$srcdir"/gopath
+ cd gopath/src/$_pkgorg/$_pkgname
+ make VERSION=$pkgver
+}
+
+package() {
+ export GOPATH="$srcdir"/gopath
+ cd gopath/src/$_pkgorg/$_pkgname
+ make DESTDIR="$pkgdir" install
+ cd -
+
+ cd $_pkgname
+ ls -al
+ install -Dm0644 systemd/muserv.service "$pkgdir"/etc/systemd/system/muserv.service
+ install -Dm0644 cfg/sysusers.conf "$pkgdir"/usr/lib/sysusers.d/muserv.conf
+ install -Dm0644 cfg/config-default.json "$pkgdir"/etc/muserv/config-default.json
+ install -Dm0644 cfg/ContentDirectory.xml "$pkgdir"/etc/muserv/ContentDirectory.xml
+ install -Dm0644 cfg/ConnectionManager.xml "$pkgdir"/etc/muserv/ConnectionManager.xml
+}