summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrittany Figueroa2022-03-28 09:38:22 -0700
committerBrittany Figueroa2022-03-28 09:38:22 -0700
commit50bbc26c85f90fb3f4fed8bcaa5bd954c9860524 (patch)
tree24d7c9bb5b26342a811fde0c392cd526aa0bfbc2 /PKGBUILD
parente224eae81e262cb11ad91bd7b7851698e213cb01 (diff)
downloadaur-50bbc26c85f90fb3f4fed8bcaa5bd954c9860524.tar.gz
Changed authors
Signed-off-by: Brittany Figueroa <>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 16 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5002ef6f82d5..ade549ef06c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,9 @@
-# Maintainer: Brad Erhart <tocusso underscore malty at aleeas dot com>
+# Maintainer: Brittany Figueroa <dormwear underscore iure at crowley dot seership dot dev>
pkgname=musixmatch-bin
-_pkgname=${pkgname%-bin}
-pkgver=3.10.4043
-_pkgver=master.20200211001
-pkgrel=4
+_pkgname="${pkgname%-bin}"
+pkgver='3.10.4043_master.20200211001'
+pkgrel=5
pkgdesc='Lyrics for your music'
arch=('x86_64')
url='https://about.musixmatch.com/apps'
@@ -18,26 +17,21 @@ depends=(
'libxtst'
'nss'
)
-optdepends=('spotify: Instant synchronised lyrics')
-source=(
- "https://download-app.musixmatch.com/download/${_pkgname}_$pkgver-${_pkgver}_amd64.deb"
- 'eula.md'
-)
-sha256sums=(
- 'f1dbb249f5622a7b5bb62bc53616c5579b79029aee8c7ff7ecc27f11c12e7bd1'
- '9fe25570f514c1a9349769bedbbff9e48ad8c09ee4d77fa9492e46e6e9eb9eaf'
-)
+optdepends=('spotify: Instant synchronized lyrics')
+source=("https://download-app.musixmatch.com/download/${_pkgname}_${pkgver}-${_pkgver}_amd64.deb")
+b2sums=('85272ec57171512476f293b0b411427118bb75aa536703faf337f4d516006ed23a386f62f0fa83fdd040ecda7d77ceb38f89801da8dba84ddb0ba50a0d187094')
prepare() {
- tar xf data.tar.xz
- sed -i 's,;x-scheme-handler/mxm,,' usr/share/mime/packages/$_pkgname.xml
- sed -i 's,/opt/Musixmatch/,,' usr/share/applications/$_pkgname.desktop
- mkdir -p usr/lib/$_pkgname "$pkgdir"
- mv opt/Musixmatch/resources/app.asar usr/lib/$_pkgname
+ tar \
+ --extract \
+ --file data.tar.xz
+ sed --in-place 's/;x-scheme-handler\/mxm//' "usr/share/mime/packages/${_pkgname}.xml"
+ sed --in-place 's/\/opt\/Musixmatch\///' "usr/share/applications/${_pkgname}.desktop"
}
package() {
- mv usr "$pkgdir"
- install -D eula.md -t "$pkgdir/usr/share/licenses/$_pkgname"
- echo -e '#!/bin/sh\n\nexec electron9 /usr/lib/musixmatch/app.asar "$@"' | install -Dm 755 /dev/stdin "$pkgdir/usr/bin/$_pkgname"
+ mv 'usr' "${pkgdir}"
+ install -D 'opt/Musixmatch/resources/app.asar' --target-directory "${pkgdir}/usr/lib/${_pkgname}"
+ echo -e '# Musixmatch EULA\n<https://about.musixmatch.com/eula>' | install -D /dev/stdin "${pkgdir}/usr/share/licenses/${_pkgname}/eula.md"
+ echo -e "#!/bin/sh\n\nexec electron9 /usr/lib/${_pkgname}/app.asar \"\$@\"" | install -D --mode 755 /dev/stdin "${pkgdir}/usr/bin/${_pkgname}"
}