summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSean Greenslade2015-06-21 21:58:20 -0500
committerSean Greenslade2015-06-21 21:58:20 -0500
commitc2e8cdd299b87afb7002c0b34cf2d5e75e379aba (patch)
treee28eed602c4d18ec75cacdbc41bac35a74970abf /PKGBUILD
downloadaur-c2e8cdd299b87afb7002c0b34cf2d5e75e379aba.tar.gz
Initial copy over from AUR3.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..443f09dd3a46
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Sean Greenslade <sean at seangreenslade dot com>
+# Contributor: Jon Gjengset
+# Contributor: jsteel <mail at jsteel dot org>
+# Contributor: andreas_baumann <abaumann at yahoo dot com>
+# Contributor: tobias [tobias [at] archlinux.org]
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+
+_pkgbase=mutt
+pkgname=${_pkgbase}-slang
+pkgver=1.5.23
+pkgrel=2
+pkgdesc='Small but very powerful text-based mail client'
+url='http://www.mutt.org/'
+provides=('mutt')
+conflicts=('mutt')
+license=('GPL')
+backup=('etc/Muttrc')
+arch=('i686' 'x86_64')
+optdepends=('smtp-forwarder: to send mail')
+depends=('gpgme' 'slang' 'openssl' 'libsasl' 'gdbm' 'libidn' 'mime-types' 'krb5')
+source=("https://bitbucket.org/mutt/mutt/downloads/${_pkgbase}-${pkgver}.tar.gz")
+sha256sums=('3af0701e57b9e1880ed3a0dee34498a228939e854a16cdccd24e5e502626fd37')
+
+install=${pkgname}.install
+
+build() {
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-gpgme \
+ --enable-pop \
+ --enable-imap \
+ --enable-smtp \
+ --enable-hcache \
+ --with-slang=/usr \
+ --with-regex \
+ --with-gss=/usr \
+ --with-ssl=/usr \
+ --with-sasl \
+ --with-idn \
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ rm "${pkgdir}"/etc/mime.types{,.dist}
+ rm "${pkgdir}"/usr/bin/{flea,muttbug}
+ rm "${pkgdir}"/usr/share/man/man1/{flea,muttbug}.1
+ install -Dm644 contrib/gpg.rc "${pkgdir}"/etc/Muttrc.gpg.dist
+}