summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTérence Clastres2018-11-15 23:07:49 +0100
committerTérence Clastres2018-11-15 23:07:49 +0100
commit94c0b035483c564b6dafb9730399d0b28a04426b (patch)
treefce360897a2a1e9eb4c78ddb839d7fc276099de3 /PKGBUILD
parent3439310e49ae7deb7cebdb4e18f1baf07e4fa032 (diff)
downloadaur-94c0b035483c564b6dafb9730399d0b28a04426b.tar.gz
3.30.2
Use one line cherry-pick A^..B format Update some commit hashes Remove patch already applied by upstream package Add new patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 15 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd6781a296ac..1c7ae6cd7ccf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@
pkgname=mutter-781835-workaround
_pkgname=mutter
-pkgver=3.30.1+8+g1abab3fe2
-pkgrel=3
+pkgver=3.30.2+5+g108380cc2
+pkgrel=1
pkgdesc="A window manager for GNOME. This package reverts a commit which may causes performance problems for nvidia driver users. Some performance patches also included."
url="https://gitlab.gnome.org/GNOME/mutter"
arch=(x86_64)
@@ -20,7 +20,7 @@ makedepends=(intltool gobject-introspection git egl-wayland)
provides=(mutter)
conflicts=(mutter)
groups=(gnome)
-_commit=1abab3fe2ed2d07bafc9f3aabe188c4d1c05ee43 # gnome-3-30
+_commit=bcd6103c44ff74ebffd1737b8e0f3a952b83bd54 # tags/3.30.2^0
source=("git+https://gitlab.gnome.org/GNOME/mutter.git#commit=$_commit"
https://gitlab.gnome.org/vanvugt/mutter/commit/fc02b040f3b750b0513f812813351c09795950f6.patch
startup-notification.patch
@@ -30,10 +30,10 @@ sha256sums=('SKIP'
'00d5e77c94e83e1987cc443ed7c47303aa33367ce912b2f665bcd34f88890a17'
'2d2e305e0a6cca087bb8164f81bdc0ae7a5ca8e9c13c81d7fd5252eb3563fc09')
-# pkgver() {
-# cd $_pkgname
-# # git describe --tags | sed 's/-/+/g'
-# }
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
prepare() {
cd $_pkgname
@@ -56,21 +56,21 @@ prepare() {
# Geometric (GPU-less) picking
# https://gitlab.gnome.org/GNOME/mutter/merge_requests/189
- git cherry-pick 0fe913fe
- git cherry-pick 955d9c07
+ git cherry-pick 0fe913fe^..955d9c07
# Sync to the hardware refresh rate, not just 60.00Hz [performance]
# https://gitlab.gnome.org/GNOME/mutter/merge_requests/171/commits
- git cherry-pick d29a1c4a
- git cherry-pick 7575c7fa
+ # Disabled as requires to solve conflicts
+ #git cherry-pick cc28298c^..3947a4de || bash
# clutter-actor: Add detail to captured-event signal [performance]
# https://gitlab.gnome.org/GNOME/mutter/merge_requests/283/commits
- git cherry-pick 544b95de
+ git cherry-pick c2404d16
- # cogl-winsys-glx: Fix frame notification race/leak [performance]
- # https://gitlab.gnome.org/GNOME/mutter/merge_requests/216
- git cherry-pick fc02b040
+
+ # clutter-stage-cogl: Reduce output latency and reduce missed frames too [performance]
+ # https://gitlab.gnome.org/GNOME/mutter/merge_requests/281/commits
+ git cherry-pick bd44e7d3^..b07f9b86
# '
# Commented multiline comment end, remove the # above if disabling the patches