summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoakim Soderlund2022-04-07 09:49:21 +0200
committerJoakim Soderlund2022-04-07 10:33:54 +0200
commitbb703a841934ed1cf3ef73ac5903b2394cddc070 (patch)
tree26cee21db3f9718d970e1241f166b7edbe4d25d2 /PKGBUILD
parentaea1a30553e79892c06142fbd53ff557462cfe3a (diff)
downloadaur-bb703a841934ed1cf3ef73ac5903b2394cddc070.tar.gz
Upgrade Mutter to version 42.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 32 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ea482f90aa02..c0039104b741 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,23 @@
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Michael Kanis <mkanis_at_gmx_dot_de>
-pkgname=mutter-dynamic-buffering
-pkgver=41.5
+pkgbase=mutter-dynamic-buffering
+pkgname=(mutter-dynamic-buffering)
+pkgver=42.0
pkgrel=1
pkgdesc="A window manager for GNOME (with dynamic triple/double buffering)"
url="https://gitlab.gnome.org/GNOME/mutter"
arch=(x86_64)
license=(GPL)
depends=(dconf gobject-introspection-runtime gsettings-desktop-schemas
- libcanberra startup-notification zenity libsm gnome-desktop upower
+ libcanberra startup-notification zenity libsm gnome-desktop
libxkbcommon-x11 gnome-settings-daemon libgudev libinput pipewire
xorg-xwayland graphene libxkbfile libsysprof-capture)
makedepends=(gobject-introspection git egl-wayland meson xorg-server
- wayland-protocols sysprof)
+ wayland-protocols sysprof gi-docgen)
#checkdepends=(xorg-server-xvfb pipewire-media-session python-dbusmock)
-provides=(mutter libmutter-9.so)
-conflicts=(mutter)
-groups=(gnome)
#options=(debug)
-_commit=17926e941d67867911c462737f4d013adb55e4d6 # tags/41.5^0
+_commit=9249aba72a5c4454894c08735a4963ca1665e34d # tags/42.0^0
source=("$pkgname::git+https://gitlab.gnome.org/GNOME/mutter.git#commit=$_commit"
'backports.patch'
'mr1441.patch')
@@ -39,9 +37,6 @@ prepare() {
cd "$srcdir/$pkgname"
patch -p1 < "$srcdir/mr1441.patch"
patch -p1 < "$srcdir/backports.patch"
-
- # Make tests run
- sed -i '/catchsegv/d' meson.build
}
build() {
@@ -50,6 +45,7 @@ build() {
arch-meson $pkgname build \
-D egl_device=true \
-D wayland_eglstream=true \
+ -D docs=true \
-D installed_tests=false \
-D tests=false
meson compile -C build
@@ -68,7 +64,7 @@ _check_internal() (
trap "kill $_p1 $_p2; wait" EXIT
- meson test -C build --print-errorlogs
+ meson test -C build --print-errorlogs -t 3
)
_check_disabled() {
@@ -76,6 +72,29 @@ _check_disabled() {
bash -c "$(declare -f _check_internal); _check_internal"
}
-package() {
+_pick() {
+ local p="$1" f d; shift
+ for f; do
+ d="$srcdir/$p/${f#$pkgdir/}"
+ mkdir -p "$(dirname "$d")"
+ mv "$f" "$d"
+ rmdir -p --ignore-fail-on-non-empty "$(dirname "$f")"
+ done
+}
+
+package_mutter-dynamic-buffering() {
+ conflicts=(mutter)
+ provides=(mutter libmutter-10.so)
+ groups=(gnome)
+
meson install -C build --destdir "$pkgdir"
+
+ _pick docs "$pkgdir"/usr/share/mutter-*/doc
+}
+
+package_mutter-docs() {
+ pkgdesc+=" (documentation)"
+ depends=()
+
+ mv docs/* "$pkgdir"
}