summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabian Bornschein2021-12-04 11:15:11 +0100
committerFabian Bornschein2021-12-04 11:15:11 +0100
commitb473a11d72513f1e4bf662c6ddf52a4fc692da8d (patch)
tree5d16ae8695fdbaff9c941cce4aeb320a967ca6c9 /PKGBUILD
parent2e3c9cda95ae8d8bcd77dddda5fefc59b87ef6c6 (diff)
downloadaur-b473a11d72513f1e4bf662c6ddf52a4fc692da8d.tar.gz
New upstream release: 40.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dff32bd825c3..7e15beb25306 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Michael Kanis <mkanis_at_gmx_dot_de>
pkgname=mutter-oldstable
-pkgver=3.38.6
+pkgver=40.6
pkgrel=1
pkgdesc="A window manager for GNOME (oldstable version)"
url="https://gitlab.gnome.org/GNOME/mutter"
@@ -17,12 +17,12 @@ depends=(dconf gobject-introspection-runtime gsettings-desktop-schemas-oldstable
libcanberra startup-notification zenity libsm gnome-desktop upower
libxkbcommon-x11 gnome-settings-daemon-oldstable libgudev libinput pipewire
xorg-xwayland graphene libxkbfile)
-makedepends=(gobject-introspection git egl-wayland meson xorg-server)
+makedepends=(gobject-introspection git egl-wayland meson xorg-server
+ wayland-protocols)
checkdepends=(xorg-server-xvfb pipewire-media-session)
-provides=(libmutter-7.so)
+provides=(libmutter-8.so)
groups=(gnome-oldstable)
-install=mutter.install
-_commit=8bf8474372ea66ee7cccf369a95f6be83109681e # tag/3.38.6
+_commit=48f4306b738b079d3758595cdb6ab7f6a1f821c8 # tag/40.6
source=("git+https://gitlab.gnome.org/GNOME/mutter.git#commit=$_commit")
sha256sums=('SKIP')
@@ -59,16 +59,15 @@ _check() (
trap "kill $_p1 $_p2; wait" EXIT
- meson test -C build --print-errorlogs || true
+ meson test -C build --print-errorlogs
)
check() {
-# Check might fail without clean build env. Continue building in any case.
dbus-run-session xvfb-run \
-s '-screen 0 1920x1080x24 -nolisten local +iglx -noreset' \
bash -c "$(declare -f _check); _check"
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "$pkgdir"
}